Availability Calendar < 1.2.1 - Authenticated SQL Injection
Priority MEDIUM 41CWE-89Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- SQL injection
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-89.
Summary
The Availability Calendar WordPress plugin before 1.2.1 does not escape the category attribute from its shortcode before using it in a SQL statement, leading to a SQL Injection issue, which can be exploited by any user able to add shortcode to posts/pages, such as contributor+
Why it matters now
EPSS 0.01334 71st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Availability Calendar (Unknown): 1.2.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Availability Calendar | 1.2.1 to before 1.2.1 | 1.2.1 | Patch available | CNA |
- Availability Calendar VendorUnknown Affected 1.2.1 to before 1.2.1 Fixed in 1.2.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:offshorewebmaster:availability_calendar:*:*:*:*:*:wordpress:*:* | before 1.2.1 | Vulnerable | Offshore Web Master |
- cpe:2.3:a:offshorewebmaster:availability_calendar:*:*:*:*:*:wordpress:*:* Versions before 1.2.1 Vulnerable ·Offshore Web Master
Remediation
- Fix · CNA Availability Calendar (Unknown) Fixed in 1.2.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24606
- 2026-10-03 Alias added: GHSA-rj93-7769-mc4j
References
More Offshore Web Master Availability Calendar vulnerabilities
- TI-2023-26574 WordPress Availability Calendar Plugin <= 1.2.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2021-06887 Availability Calendar < 1.2.2 - Authenticated Stored Cross-Site Scripting CVSS 3.1MEDIUM 4.8
Sources
- CVE-2021-24606 · CVE Program
- CVE-2021-24606 · NVD
- FIRST EPSS
- GHSA-rj93-7769-mc4j · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences