Formidable Form Builder < 5.0.07 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Formidable Form Builder – Contact Form, Survey & Quiz Forms Plugin for WordPress plugin before 5.0.07 does not sanitise and escape its Form's Labels, allowing high privileged users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00676 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Formidable Form Builder – Contact Form, Survey & Quiz Forms Plugin for WordPress (Unknown): 5.0.07
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Formidable Form Builder – Contact Form, Survey & Quiz Forms Plugin for WordPress | 5.0.07 to before 5.0.07 | 5.0.07 | Patch available | CNA |
- Formidable Form Builder – Contact Form, Survey & Quiz Forms Plugin for WordPress VendorUnknown Affected 5.0.07 to before 5.0.07 Fixed in 5.0.07 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:strategy11:formidable_form_builder:*:*:*:*:*:wordpress:*:* | before 5.0.07 | Vulnerable | strategy11team |
- cpe:2.3:a:strategy11:formidable_form_builder:*:*:*:*:*:wordpress:*:* Versions before 5.0.07 Vulnerable ·strategy11team
Remediation
- Fix · CNA Formidable Form Builder – Contact Form, Survey & Quiz Forms Plugin for WordPress (Unknown) Fixed in 5.0.07
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24608
- 2026-10-03 Alias added: GHSA-76gr-jrfv-xpv4
References
More strategy11team Formidable Form Builder vulnerabilities
- TI-2023-00774 Formidable Forms < 6.1 - IP Spoofing CVSS 3.1MEDIUM 6.5
- TI-2021-07166 Formidable Form Builder < 4.09.05 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1CRITICAL 9.6
- TI-2019-11851 The formidable plugin before 4.02.01 for WordPress has unsafe deserialization. CVSS 3.1CRITICAL 9.8
- TI-2017-14258 Formidable Form Builder < 2.05.03 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 8.3
- TI-2023-10041 WordPress Formidable Forms Plugin <= 5.5.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2023-06236 Formidable Forms <= 6.7 - HTML Injection CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24608 · CVE Program
- CVE-2021-24608 · NVD
- FIRST EPSS
- GHSA-76gr-jrfv-xpv4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences