TranslatePress < 2.0.9 - Authenticated Stored Cross-Site Scripting
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The TranslatePress WordPress plugin before 2.0.9 does not implement a proper sanitisation on the translated strings. The 'trp_sanitize_string' function only removes script tag with a regex, still allowing other HTML tags and attributes to execute javascript, which could lead to authenticated Stored Cross-Site Scripting issues.
Why it matters now
EPSS 0.05432 92nd percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Translate Multilingual sites – TranslatePress (Unknown): 2.0.9
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Translate Multilingual sites – TranslatePress | 2.0.9 to before 2.0.9 | 2.0.9 | Patch available | CNA |
- Translate Multilingual sites – TranslatePress VendorUnknown Affected 2.0.9 to before 2.0.9 Fixed in 2.0.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:cozmoslabs:translatepress:*:*:*:*:*:wordpress:*:* | before 2.0.9 | Vulnerable | Cozmoslabs |
- cpe:2.3:a:cozmoslabs:translatepress:*:*:*:*:*:wordpress:*:* Versions before 2.0.9 Vulnerable ·Cozmoslabs
Remediation
- Fix · CNA Translate Multilingual sites – TranslatePress (Unknown) Fixed in 2.0.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24610
- 2026-10-03 Alias added: GHSA-79hx-hhr4-x2xv
References
More Cozmoslabs Translatepress vulnerabilities
- TI-2022-02900 Translatepress Multilinugal < 2.3.3 - Admin+ SQLi CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24610 · CVE Program
- CVE-2021-24610 · NVD
- FIRST EPSS
- GHSA-79hx-hhr4-x2xv · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences