WP Courses LMS < 2.0.44 - Authenticated Stored XSS via Video Embed Code
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP Courses LMS WordPress plugin before 2.0.44 does not sanitise its Video Embed Code, allowing malicious code to be injected in it by high privilege users, even when the unfiltered_html capability is disallowed, which could lead to Stored Cross-Site Scripting issues
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Courses LMS (Unknown): 2.0.44
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Courses LMS | 2.0.44 to before 2.0.44 | 2.0.44 | Patch available | CNA |
- WP Courses LMS VendorUnknown Affected 2.0.44 to before 2.0.44 Fixed in 2.0.44 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:stratospheredigital:wp_courses_lms:*:*:*:*:*:wordpress:*:* | before 2.0.44 | Vulnerable | Stratospheredigital |
- cpe:2.3:a:stratospheredigital:wp_courses_lms:*:*:*:*:*:wordpress:*:* Versions before 2.0.44 Vulnerable ·Stratospheredigital
Remediation
- Fix · CNA WP Courses LMS (Unknown) Fixed in 2.0.44
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24621
- 2026-10-03 Alias added: GHSA-8jw6-mfpx-fgw6
References
Sources
- CVE-2021-24621 · CVE Program
- CVE-2021-24621 · NVD
- FIRST EPSS
- GHSA-8jw6-mfpx-fgw6 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences