Read the docs
TI-2021-06962 Aliases CVE-2021-24680GHSA-3v2q-4w56-hr98

WP Travel Engine < 5.3.1 - Editor+ Stored Cross-Site Scripting

Priority LOW 25CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Travel Engine WordPress plugin before 5.3.1 does not escape the Description field in the Trip Destination/Activities/Trip Type and Pricing Category pages, allowing users with a role as low as editor to perform Stored Cross-Site Scripting attacks, even when the unfiltered_html capability is disallowed

Why it matters now

EPSS 0.00624 50th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Travel Engine – Travel and Tour Booking Plugin (Unknown): 5.3.1

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Travel Engine – Travel and Tour Booking Plugin5.3.1 to before 5.3.15.3.1Patch availableCNA
  • WP Travel Engine – Travel and Tour Booking Plugin VendorUnknown Affected 5.3.1 to before 5.3.1 Fixed in 5.3.1 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wptravelengine:wp_travel_engine:*:*:*:*:*:wordpress:*:*before 5.3.1Vulnerablewptravelengine
  • cpe:2.3:a:wptravelengine:wp_travel_engine:*:*:*:*:*:wordpress:*:* Versions before 5.3.1 Vulnerable ·wptravelengine

Remediation

  • Fix · CNA WP Travel Engine – Travel and Tour Booking Plugin (Unknown) Fixed in 5.3.1

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24680
  2. 2026-10-03 Alias added: GHSA-3v2q-4w56-hr98
  3. 2026-11-04 EPSS moved to the 50th–90th percentile

References

  • TI-2024-20226 WordPress WP Travel Engine plugin <= 5.7.9 - Unauth. Blind SQL Injection vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-22140 WordPress WP Travel Engine plugin <= 6.3.5 - Local File Inclusion vulnerability CVSS 3.1CRITICAL 9.8
  • TI-2025-04745 WP Travel Engine <= 6.5.1 - Missing Authorization to Unauthenticated Arbitrary Post Deletion CVSS 3.1HIGH 7.5
  • TI-2024-21672 WordPress WP Travel Engine plugin <= 5.8.0 - Price Manipulation vulnerability CVSS 3.1HIGH 7.5
  • TI-2025-22141 WordPress WP Travel Engine plugin <= 6.3.5 - Local File Inclusion vulnerability CVSS 3.1HIGH 7.5
  • TI-2024-20228 WordPress WP Travel Engine plugin <= 5.7.9 - SQL Injection vulnerability CVSS 3.1HIGH 7.6
See all 8 →

Sources