Forminator < 1.15.4 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Forminator WordPress plugin before 1.15.4 does not sanitize and escape the email field label, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Forminator – Contact Form, Payment Form & Custom Form Builder (Unknown): 1.15.4
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Forminator – Contact Form, Payment Form & Custom Form Builder | 1.15.4 to before 1.15.4 | 1.15.4 | Patch available | CNA |
- Forminator – Contact Form, Payment Form & Custom Form Builder VendorUnknown Affected 1.15.4 to before 1.15.4 Fixed in 1.15.4 Patch available CNA
Remediation
- Fix · CNA Forminator – Contact Form, Payment Form & Custom Form Builder (Unknown) Fixed in 1.15.4
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24700
- 2026-10-03 Alias added: GHSA-w47h-56cf-m4g5
References
More Incsub Forminator vulnerabilities
- TI-2023-04240 Forminator <= 1.24.6 - Unauthenticated Arbitrary File Upload CVSS 3.1CRITICAL 9.8
- TI-2025-05864 Forminator Forms – Contact Form, Payment Form & Custom Form Builder <= 1.44.2… CVSS 3.1HIGH 8.8
- TI-2024-20466 SQL injection in wpmudev Forminator CVSS 3.1HIGH 7.2
- TI-2023-01891 Forminator < 1.24.1 - Unauthenticated Race Condition on poll vote CVSS 3.1LOW 3.1
- TI-2024-06849 Forminator <= 1.29.1 - HubSpot Developer API Key Sensitive Information Exposure CVSS 3.1HIGH 7.5
- TI-2025-05865 Deserialization of untrusted data in wpmudev Forminator Forms – Contact Form, Payment… CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24700 · CVE Program
- CVE-2021-24700 · NVD
- FIRST EPSS
- GHSA-w47h-56cf-m4g5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences