WP RSS Aggregator < 4.19.2 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WP RSS Aggregator WordPress plugin before 4.19.2 does not properly sanitise and escape the URL to Blacklist field, allowing malicious HTML to be inserted by high privilege users even when the unfiltered_html capability is disallowed, which could lead to Cross-Site Scripting issues.
Why it matters now
EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More (Unknown): 4.19.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More | 4.19.2 to before 4.19.2 | 4.19.2 | Patch available | CNA |
- WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More VendorUnknown Affected 4.19.2 to before 4.19.2 Fixed in 4.19.2 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wprssaggregator:wp_rss_aggregator:*:*:*:*:*:wordpress:*:* | before 4.19.2 | Vulnerable | Wprssaggregator |
- cpe:2.3:a:wprssaggregator:wp_rss_aggregator:*:*:*:*:*:wordpress:*:* Versions before 4.19.2 Vulnerable ·Wprssaggregator
Remediation
- Fix · CNA WP RSS Aggregator – News Feeds, Autoblogging, Youtube Video Feeds and More (Unknown) Fixed in 4.19.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24768
- 2026-10-03 Alias added: GHSA-4q83-54pp-rmxj
References
More Wprssaggregator Wp Rss Aggregator vulnerabilities
- TI-2022-00128 WP RSS Aggregator < 4.20 - Reflected Cross-Site Scripting (XSS) CVSS 3.1MEDIUM 6.1
- TI-2021-07267 WP RSS Aggregator < 4.19.3 - Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
- TI-2024-00585 WP RSS Aggregator <= 4.23.4 - Authenticated (Admin+) Stored Cross-Site Scripting via RSS Feed Source CVSS 3.1MEDIUM 4.8
- TI-2024-00583 Server-side request forgery in jeangalea WP RSS Aggregator – RSS Import, News Feeds, Feed… CVSS 3.1LOW 3.8
Sources
- CVE-2021-24768 · CVE Program
- CVE-2021-24768 · NVD
- FIRST EPSS
- GHSA-4q83-54pp-rmxj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences