BP Better Messages < 1.9.9.41 - Multiple CSRF
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352.
Summary
The BP Better Messages WordPress plugin before 1.9.9.41 does not check for CSRF in multiple of its AJAX actions: bp_better_messages_leave_chat, bp_better_messages_join_chat, bp_messages_leave_thread, bp_messages_mute_thread, bp_messages_unmute_thread, bp_better_messages_add_user_to_thread, bp_better_messages_exclude_user_from_thread. This could allow attackers to make logged in users do unwanted actions
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | BP Better Messages | 1.9.9.41 to before 1.9.9.41 | 1.9.9.41 | Patch available | CNA |
- BP Better Messages VendorUnknown Affected 1.9.9.41 to before 1.9.9.41 Fixed in 1.9.9.41 Patch available CNA
Remediation
- Fix · CNA BP Better Messages (Unknown) Fixed in 1.9.9.41
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
BP Better Messages 1.9.9.41
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-07090 BP Better Messages < 1.9.9.41 - Reflected Cross-Site ScriptingPriority LOW 29
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24809
- 2026-10-03 Alias added: GHSA-mh56-9pvx-f58x
References
More wordplus Better Messages vulnerabilities
- TI-2024-12652 Information disclosure in wordplus Better Messages – Live Chat, Chat Rooms, Real-Time… CVSS 3.1HIGH 7.5
- TI-2022-20012 WordPress Better Messages plugin <= 1.9.10.68 - Server-Side Request Forgery (SSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2022-16728 WordPress Better Messages plugin <= 1.9.9.148 - Cross-Site Request Forgery (CSRF) vulnerability CVSS 3.1HIGH 8.8
- TI-2022-14581 WordPress Better Messages plugin <= 1.9.10.57 - Denial Of Service (DoS) vulnerability CVSS 3.1HIGH 7.7
- TI-2024-12736 Server-side request forgery in wordplus Better Messages – Live Chat, Chat Rooms… CVSS 3.1MEDIUM 6.5
- TI-2023-26827 WordPress BP Better Messages Plugin <= 2.4.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24809 · CVE Program
- CVE-2021-24809 · NVD
- FIRST EPSS
- GHSA-mh56-9pvx-f58x · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences