Read the docs
TI-2021-07092 Aliases CVE-2021-24810GHSA-p7xr-9xx7-g45r

WP Event Manager < 3.1.23 - Admin+ Stored Cross-Site Scripting

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The WP Event Manager WordPress plugin before 3.1.23 does not escape some of its Field Editor settings when outputting them, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed

Why it matters now

EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WP Event Manager – Easily Build your Calendar of Events! (Unknown): 3.1.23

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownWP Event Manager – Easily Build your Calendar of Events!3.1.23 to before 3.1.233.1.23Patch availableCNA
  • WP Event Manager – Easily Build your Calendar of Events! VendorUnknown Affected 3.1.23 to before 3.1.23 Fixed in 3.1.23 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:wp-eventmanager:wp_event_manager:*:*:*:*:*:wordpress:*:*before 3.1.23VulnerableWP Event Manager
  • cpe:2.3:a:wp-eventmanager:wp_event_manager:*:*:*:*:*:wordpress:*:* Versions before 3.1.23 Vulnerable ·WP Event Manager

Remediation

  • Fix · CNA WP Event Manager – Easily Build your Calendar of Events! (Unknown) Fixed in 3.1.23

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24810
  2. 2026-10-03 Alias added: GHSA-p7xr-9xx7-g45r

References

  • TI-2025-02444 WP Event Manager <= 3.1.50 - Unauthenticated Stored Cross-Site Scripting via 'organizer_name' CVSS 3.1HIGH 7.2
  • TI-2023-25834 WordPress WP Event Manager Plugin <= 3.1.39 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
  • TI-2023-28557 WordPress WP User Profile Avatar Plugin <= 1.0 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2022-01348 WP Event Manager < 3.1.28 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2024-02506 Cross-site scripting in WP Event Manager – Events Calendar, Registrations, Sell Tickets… CVSS 3.1MEDIUM 6.4
  • TI-2024-00900 WP Event Manager <= 3.1.41 - Reflected Cross-Site Scripting via plugin CVSS 3.1MEDIUM 6.1
See all 9 →

Sources