Cost Calculator < 1.6 - Contributor+ Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Cost Calculator WordPress plugin before 1.6 allows users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks via the Description fields of a Cost Calculator > Price Settings (which gets injected on the edit page as well as any page that embeds the calculator using the shortcode), as well as the Text Preview field of a Project (injected on the edit project page)
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Cost Calculator | 1.6 to before 1.6 | 1.6 | Patch available | CNA |
- Cost Calculator VendorUnknown Affected 1.6 to before 1.6 Fixed in 1.6 Patch available CNA
Remediation
- Fix · CNA Cost Calculator (Unknown) Fixed in 1.6
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24821
- 2026-10-03 Alias added: GHSA-p6g4-5hgj-p576
References
More nicdark Cost Calculator vulnerabilities
- TI-2023-00159 Cost Calculator <= 1.8 - Contributor+ Stored XSS CVSS 3.1MEDIUM 5.4
- TI-2023-01093 Cost Calculator <= 1.8 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24821 · CVE Program
- CVE-2021-24821 · NVD
- FIRST EPSS
- GHSA-p6g4-5hgj-p576 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences