Priority HIGH 73
The ND Shortcodes WordPress plugin before 7.0 does not validate some shortcode attributes before using them to generate paths passed to include function/s, allowing any authenticated users such as subscriber to perform L…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.01683 · Published 2023-07-04 · Fixed in 7.0
Priority MEDIUM 58
The Cost Calculator WordPress plugin through 1.8 does not validate and escape some of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the con…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00471 · Published 2023-03-06 · No fix listed CWE-79
Priority MEDIUM 58
The ND Shortcodes WordPress plugin before 7.0 does not validate and escape numerous of its shortcode attributes before outputting them back in a page/post where the shortcode is embed, which could allow users with the co…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00444 · Published 2023-07-04 · Fixed in 7.0
Priority MEDIUM 42
The Restaurant Reservations plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 1.9 via the nd_rst_layout attribute of the nd_rst_search shortcode.
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.0088 · Published 2024-03-07 · No fix listed CWE-98
Priority MEDIUM 41
The Elements For Elementor plugin for WordPress is vulnerable to Local File Inclusion in all versions up to, and including, 2.1 via the 'beforeafter_layout' attribute of the beforeafter widget, the 'eventsgrid_layout' at…
CVSS 3.1HIGH 8.8· Network · Low privileges · No interaction · EPSS 0.00802 · Published 2024-06-01 · No fix listed CWE-98
Priority LOW 38
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in nicdark Hotel Booking nd-booking allows PHP Local File Inclusion.This issue affects Hotel Booking:…
CVSS 3.1HIGH 8.1· Network · No auth · No interaction · EPSS 0.00675 · Published 2025-04-17 · No fix listed CWE-98
Priority LOW 36
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in nicdark Hotel Booking nd-booking allows PHP Local File Inclusion.This issue affects Hotel Booking:…
CVSS 3.1HIGH 7.5· Network · Low privileges · No interaction · EPSS 0.00733 · Published 2025-06-27 · No fix listed CWE-98
Priority LOW 36
Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in nicdark Hotel Booking nd-booking allows PHP Local File Inclusion.This issue affects Hotel Booking:…
CVSS 3.1HIGH 7.5· Network · Low privileges · No interaction · EPSS 0.00778 · Published 2025-05-07 · No fix listed CWE-98
Priority LOW 30
Unauthenticated Cross Site Scripting (XSS) in Hotel Booking <= 3.8 versions.
CVSS 3.1HIGH 7.1· Network · No auth · User interaction · EPSS 0.00175 · Published 2026-10-06 · No fix listed CWE-79
Priority LOW 30
Missing Authorization vulnerability in nicdark Hotel Booking nd-booking allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects Hotel Booking: from n/a through <= 3.8.
CVSS 3.1MEDIUM 5.3· Network · No auth · No interaction · EPSS 0.00263 · Published 2025-12-31 · No fix listed CWE-862
Priority LOW 29
Subscriber Insecure Direct Object References (IDOR) in Hotel Booking <= 3.8 versions.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00326 · Published 2026-10-29 · No fix listed CWE-639
Priority LOW 29
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Nicdark Restaurant Reservations allows Stored XSS.This issue affects Restaurant Reservations: from n/a through 1.8.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00328 · Published 2024-02-12 · No fix listed CWE-79
Priority LOW 29
The Cost Calculator plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the nd_cc_meta_box_cc_price_icon parameter in versions up to, and including, 1.8 due to insufficient input sanitization and output…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00476 · Published 2023-03-02 · No fix listed CWE-79
Priority LOW 28
Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in nicdark ND Shortcodes For Visual Composer nd-shortcodes allows Stored XSS.This issue affects ND Shortcodes For Visual…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.0017 · Published 2026-10-22 · No fix listed CWE-79
Priority LOW 28
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in Nicdark Restaurant Reservations allows Stored XSS.This issue affects Restaurant Reservations: from n/a through…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00254 · Published 2024-07-22 · No fix listed CWE-79
Priority LOW 28
The ND Shortcodes plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's upload feature in all versions up to, and including, 7.5 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00322 · Published 2024-05-25 · No fix listed CWE-79
Priority LOW 26
Multiple Authenticated (contributor or higher user role) Stored Cross-Site Scripting (XSS) vulnerabilities in Nicdark d.o.o.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00669 · Published 2022-06-15 · No fix listed CWE-79
Priority LOW 25
Multiple Authenticated (contributor or higher user role) Stored Cross-Site Scripting (XSS) vulnerabilities in Nicdark's Hotel Booking plugin <= 3.0 at WordPress.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00535 · Published 2022-06-15 · No fix listed CWE-79
Priority LOW 25
Authenticated (contributor or higher role) Cross-Site Scripting (XSS) vulnerability in Donations plugin <= 1.8 on WordPress.
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00571 · Published 2022-05-13 · No fix listed CWE-79
Priority LOW 25
The Cost Calculator WordPress plugin before 1.6 allows users with a role as low as Contributor to perform Stored Cross-Site Scripting attacks via the Description fields of a Cost Calculator > Price Settings (which gets i…
CVSS 3.1MEDIUM 5.4· Network · Low privileges · User interaction · EPSS 0.00604 · Published 2022-03-07 · Fixed in 1.6 CWE-79