Advanced Access Manager < 6.8.0 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Advanced Access Manager WordPress plugin before 6.8.0 does not escape some of its settings when outputting them, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed
Why it matters now
EPSS 0.00676 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced Access Manager (Unknown): 6.8.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Advanced Access Manager | 6.8.0 to before 6.8.0 | 6.8.0 | Patch available | CNA |
- Advanced Access Manager VendorUnknown Affected 6.8.0 to before 6.8.0 Fixed in 6.8.0 Patch available CNA
Remediation
- Fix · CNA Advanced Access Manager (Unknown) Fixed in 6.8.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24830
- 2026-10-03 Alias added: GHSA-h54q-fpvg-vhq5
References
More AAM Advanced Access Manager vulnerabilities
- TI-2019-15267 Advanced Access Manager <= 5.9.8.1 - Unauthenticated Arbitrary File Read CVSS 3.1CRITICAL 9.8
- TI-2020-18378 The Advanced Access Manager plugin before 6.6.2 for WordPress allows privilege escalation… CVSS 3.1HIGH 8.8
- TI-2014-05002 WordPress Advanced Access Manager Plugin before 2.8.2 has an Arbitrary File Overwrite Vulnerability CVSS 3.1HIGH 7.2
- TI-2024-19301 WordPress Advanced Access Manager plugin <= 6.9.20 - Reflected Cross Site Scripting (XSS) vulnerability CVSS 3.1HIGH 7.1
- TI-2023-28321 WordPress Advanced Access Manager Plugin <= 6.9.18 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-27785 WordPress Advanced Access Manager Plugin <= 6.9.15 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-24830 · CVE Program
- CVE-2021-24830 · NVD
- FIRST EPSS
- GHSA-h54q-fpvg-vhq5 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences