YOP Poll < 6.3.1 - Author+ Stored Cross-Site Scripting via Preview Module
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The YOP Poll WordPress plugin before 6.3.1 is affected by a stored Cross-Site Scripting vulnerability, which exists in the Admin preview module where a user with a role as low as author is allowed to execute arbitrary script code within the context of the application. This vulnerability is due to insufficient validation of question and answer text parameters in Create Poll module.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | YOP Poll | 6.3.1 to before 6.3.1 | 6.3.1 | Patch available | CNA |
- YOP Poll VendorUnknown Affected 6.3.1 to before 6.3.1 Fixed in 6.3.1 Patch available CNA
Remediation
- Fix · CNA YOP Poll (Unknown) Fixed in 6.3.1
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
YOP Poll 6.3.1
2 records Highest priority Priority LOW 2 LOW
Other records, highest priority first
- TI-2021-07116 YOP Poll < 6.3.1 - Author+ Stored Cross-Site Scripting via Options ModulePriority LOW 28
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24833
- 2026-10-03 Alias added: GHSA-ggxf-x772-3hfw
References
More Yop-poll Yop Poll vulnerabilities
- TI-2021-06743 YOP Poll < 6.2.8 - Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2021-07116 YOP Poll < 6.3.1 - Author+ Stored Cross-Site Scripting via Options Module CVSS 3.1MEDIUM 5.4
- TI-2017-01431 Cross-site scripting in YOP Poll CVSS 3.0MEDIUM 5.4
- TI-2022-01470 YOP Poll < 6.4.3 - IP Spoofing CVSS 3.1MEDIUM 5.3
- TI-2023-05615 YOP Poll <= 6.5.26 - Race Condition to Vote Manipulation CVSS 3.1MEDIUM 5.3
Sources
- CVE-2021-24833 · CVE Program
- CVE-2021-24833 · NVD
- FIRST EPSS
- GHSA-ggxf-x772-3hfw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences