Passster < 3.5.5.9 - Protection Bypass & Arbitrary Post Access
Priority HIGH 72Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Passster WordPress plugin before 3.5.5.9 does not properly check for password, as well as that the post to be viewed is public, allowing unauthenticated users to bypass the protection offered by the plugin, and access arbitrary posts (such as private) content, by sending a specifically crafted request.
Why it matters now
Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00826 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Passster (Unknown): 3.5.5.9
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- Yes
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Passster | before 3.5.5.9 | 3.5.5.9 | Patch available | CNA |
- Passster VendorUnknown Affected before 3.5.5.9 Fixed in 3.5.5.9 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:passster_project:passter:*:*:*:*:*:wordpress:*:* | before 3.5.5.9 | Vulnerable | Passster Project |
- cpe:2.3:a:passster_project:passter:*:*:*:*:*:wordpress:*:* Versions before 3.5.5.9 Vulnerable ·Passster Project
Remediation
- Fix · CNA Passster (Unknown) Fixed in 3.5.5.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24881
- 2026-10-03 Alias added: GHSA-c58r-vwf8-vx95
References
More Passster Project Passter vulnerabilities
- TI-2021-07119 Passster < 3.5.5.8 - Contributor+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-24881 · CVE Program
- CVE-2021-24881 · NVD
- FIRST EPSS
- GHSA-c58r-vwf8-vx95 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences