Read the docs
TI-2021-07164 Aliases CVE-2021-24882GHSA-j64v-v3q7-95h7

Slideshow Gallery < 1.7.4 - Admin+ Stored Cross-Site Scripting

Priority LOW 23CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
High
User interaction
Required
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.

Summary

The Slideshow Gallery WordPress plugin before 1.7.4 does not sanitise and escape the Slide "Title", "Description", and Gallery "Title" fields, which could allow high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html is disallowed

Why it matters now

EPSS 0.00617 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Slideshow Gallery (Unknown): 1.7.4

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownSlideshow Gallery1.7.4 to before 1.7.41.7.4Patch availableCNA
  • Slideshow Gallery VendorUnknown Affected 1.7.4 to before 1.7.4 Fixed in 1.7.4 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tribulant:slideshow_gallery:*:*:*:*:*:wordpress:*:*before 1.7.4Vulnerablecontrid
  • cpe:2.3:a:tribulant:slideshow_gallery:*:*:*:*:*:wordpress:*:* Versions before 1.7.4 Vulnerable ·contrid

Remediation

  • Fix · CNA Slideshow Gallery (Unknown) Fixed in 1.7.4

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-24882
  2. 2026-10-03 Alias added: GHSA-j64v-v3q7-95h7

References

  • TI-2018-12822 SQL Injection exists in the Tribulant Slideshow Gallery plugin 1.6.8 for WordPress via… CVSS 3.0CRITICAL 9.8
  • TI-2023-13037 WordPress Slideshow Gallery Plugin <= 1.7.6 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2023-13031 WordPress Slideshow Gallery Plugin <= 1.7.6 is vulnerable to SQL Injection CVSS 3.1HIGH 7.2
  • TI-2024-20725 WordPress Slideshow Gallery LITE plugin <= 1.7.8 - Sensitive Data Exposure vulnerability CVSS 3.1MEDIUM 5.3
  • TI-2018-12823 XSS exists in the Tribulant Slideshow Gallery plugin 1.6.8 for WordPress via the… CVSS 3.0MEDIUM 6.1
  • TI-2018-12821 XSS exists in the Tribulant Slideshow Gallery plugin 1.6.8 for WordPress via the… CVSS 3.0MEDIUM 6.1
See all 7 →

Sources