YOP Poll < 6.1.2 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The YOP Poll WordPress plugin before 6.1.2 does not escape the perpage parameter before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting
Why it matters now
EPSS 0.00905 60th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed YOP Poll (Unknown): 6.1.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | YOP Poll | 6.1.2 to before 6.1.2 | 6.1.2 | Patch available | CNA |
- YOP Poll VendorUnknown Affected 6.1.2 to before 6.1.2 Fixed in 6.1.2 Patch available CNA
Remediation
- Fix · CNA YOP Poll (Unknown) Fixed in 6.1.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24885
- 2026-10-03 Alias added: GHSA-fr5j-77mg-3779
References
More Yop-poll vulnerabilities
- TI-2019-07286 The yop-poll plugin before 6.0.3 for WordPress has wp-admin/admin.php?page=yop-polls&action=view-votes poll_id XSS. CVSS 3.0MEDIUM 6.1
- TI-2022-00142 YOP Poll < 6.3.5 - Author+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2021-24885 · CVE Program
- CVE-2021-24885 · NVD
- FIRST EPSS
- GHSA-fr5j-77mg-3779 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences