Custom Dashboard & Login Page < 7.0 - Admin+ Stored Cross-Site Scripting
Priority LOW 23CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Custom Dashboard & Login Page WordPress plugin before 7.0 does not sanitise some of its settings, allowing high privilege users to perform Cross-Site Scripting attacks even when the unfiltered_html capability is disallowed.
Why it matters now
EPSS 0.00598 48th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Custom Dashboard & Login Page – AGCA (Unknown): 7.0
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Custom Dashboard & Login Page – AGCA | 7.0 to before 7.0 | 7.0 | Patch available | CNA |
- Custom Dashboard & Login Page – AGCA VendorUnknown Affected 7.0 to before 7.0 Fixed in 7.0 Patch available CNA
Remediation
- Fix · CNA Custom Dashboard & Login Page – AGCA (Unknown) Fixed in 7.0
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24944
- 2026-10-03 Alias added: GHSA-9fch-7g2x-c6hx
References
More Cusmin Absolutely Glamorous Custom Admin vulnerabilities
- TI-2024-02715 AGCA – Custom Dashboard & Login Page < 7.2.2 - Admin+ Stored XSS via Image URL CVSS 3.1MEDIUM 6.8
- TI-2021-14931 WordPress Absolutely Glamorous Custom Admin plugin <= 6.8 - Auth. Stored Cross-Site Scripting (XSS) vulnerability CVSS 3.1HIGH 8.2
Sources
- CVE-2021-24944 · CVE Program
- CVE-2021-24944 · NVD
- FIRST EPSS
- GHSA-9fch-7g2x-c6hx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences