Advanced iFrame < 2022 - Reflected Cross-Site Scripting
Priority LOW 29CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Advanced iFrame WordPress plugin before 2022 does not sanitise and escape the ai_config_id parameter before outputting it back in an admin page, leading to a Reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.008 56th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Advanced iFrame (Unknown): 2022
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Advanced iFrame | 2022 to before 2022 | 2022 | Patch available | CNA |
- Advanced iFrame VendorUnknown Affected 2022 to before 2022 Fixed in 2022 Patch available CNA
Remediation
- Fix · CNA Advanced iFrame (Unknown) Fixed in 2022
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24953
- 2026-10-03 Alias added: GHSA-mfjw-6wwh-h7vf
References
More mdempfle Advanced Iframe vulnerabilities
- TI-2025-01239 Advanced iFrame <= 2024.5 - Unauthenticated Settings Update CVSS 3.1MEDIUM 5.3
- TI-2024-16384 WordPress Advanced iFrame Plugin <= 2023.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-28336 WordPress Advanced iFrame Plugin <= 2023.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2023-04402 Advanced iFrame <= 2023.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
- TI-2025-01238 Advanced iFrame <= 2024.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Host Header CVSS 3.1MEDIUM 6.4
- TI-2025-01237 Advanced iFrame <= 2025.2 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-24953 · CVE Program
- CVE-2021-24953 · NVD
- FIRST EPSS
- GHSA-mfjw-6wwh-h7vf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences