Read the docs
TI-2023-04402 Aliases CVE-2023-4775GHSA-258f-3vwc-4rjv

Advanced iFrame <= 2023.8 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode

Priority LOW 29CWE-79Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
Cross-site scripting
Confidentiality · integrity · availability
Low · Low · None
Fix status
No fix listed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA. Impact type from CWE-79.

Summary

The Advanced iFrame plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'advanced_iframe' shortcode in versions up to, and including, 2023.8 due to insufficient input sanitization and output escaping on user supplied attributes. This makes it possible for authenticated attackers with contributor-level and above permissions to inject arbitrary web scripts in pages that will execute whenever a user accesses an injected page. CVE-2023-51690 appears to be a potential duplicate of this issue.

Why it matters now

Exploitation None reported CISA SSVC · not in CISA KEV
EPSS 0.00553 46th percentileScored 2026-11-07
Fix No fix listed No fixed version in the sources yet

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
None
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
mdempfleAdvanced iFrameup to 2023.8—No fix listedCNA
  • Advanced iFrame Vendormdempfle Affected up to 2023.8 Fixed in — No fix listed CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:tinywebgallery:advanced_iframe:*:*:*:*:*:wordpress:*:*up to 2023.8Vulnerablemdempfle
  • cpe:2.3:a:tinywebgallery:advanced_iframe:*:*:*:*:*:wordpress:*:* Versions up to 2023.8 Vulnerable ·mdempfle

Remediation

No fixed version listed by the sources yet.

Timeline

  1. 2026-10-02 Threatist record created from CVE-2023-4775
  2. 2026-10-03 Alias added: GHSA-258f-3vwc-4rjv

References

  • TI-2025-01239 Advanced iFrame <= 2024.5 - Unauthenticated Settings Update CVSS 3.1MEDIUM 5.3
  • TI-2024-16384 WordPress Advanced iFrame Plugin <= 2023.10 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2023-28336 WordPress Advanced iFrame Plugin <= 2023.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
  • TI-2021-07232 Advanced iFrame < 2022 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
  • TI-2025-01238 Advanced iFrame <= 2024.5 - Authenticated (Contributor+) Stored Cross-Site Scripting via Host Header CVSS 3.1MEDIUM 6.4
  • TI-2025-01237 Advanced iFrame <= 2025.2 - Authenticated (Contributor+) Stored Cross-Site Scripting CVSS 3.1MEDIUM 6.4
See all 8 →

Sources