LiteSpeed Cache < 4.4.4 - IP Check Bypass to Unauthenticated Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-79.
Summary
The LiteSpeed Cache WordPress plugin before 4.4.4 does not properly verify that requests are coming from QUIC.cloud servers, allowing attackers to make requests to certain endpoints by using a specific X-Forwarded-For header value. In addition, one of the endpoint could be used to set CSS code if a setting is enabled, which will then be output in some pages without being sanitised and escaped. Combining those two issues, an unauthenticated attacker could put Cross-Site Scripting payloads in pages visited by users.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | LiteSpeed Cache | 4.4.4 to before 4.4.4 | 4.4.4 | Patch available | CNA |
- LiteSpeed Cache VendorUnknown Affected 4.4.4 to before 4.4.4 Fixed in 4.4.4 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:litespeedtech:litespeed_cache:*:*:*:*:*:wordpress:*:* | before 4.4.4 | Vulnerable | litespeedtech |
- cpe:2.3:a:litespeedtech:litespeed_cache:*:*:*:*:*:wordpress:*:* Versions before 4.4.4 Vulnerable ·litespeedtech
Remediation
- Fix · CNA LiteSpeed Cache (Unknown) Fixed in 4.4.4
Fixed in the same release
Records fixed by the same vendor advisory or release, as the CNA lists them.
- Release ·
LiteSpeed Cache 4.4.4
2 records Highest priority Priority MEDIUM 1 MEDIUM, 1 LOW
Other records, highest priority first
- TI-2021-07242 LiteSpeed Cache < 4.4.4 - Admin+ Reflected Cross-Site ScriptingPriority LOW 23
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24964
- 2026-10-03 Alias added: GHSA-fg4h-vrcg-56rq
References
More litespeedtech Litespeed Cache vulnerabilities
- TI-2024-29589 WordPress LiteSpeed Cache plugin < 6.5.0.1 - Unauthenticated Account Takeover via Cookie Leak vulnerability CVSS 3.1CRITICAL 9.8
- TI-2024-18601 WordPress LiteSpeed Cache plugin <= 6.3.0.1 - Unauthenticated Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-20892 WordPress LiteSpeed Cache plugin <= 5.7 - Unauthenticated Site Wide Stored XSS vulnerability CVSS 3.1HIGH 8.3
- TI-2023-04040 LiteSpeed Cache <= 5.6 - Authenticated (Contributor+) Stored Cross-Site Scripting via Shortcode CVSS 3.1MEDIUM 6.4
- TI-2024-33979 WordPress LiteSpeed Cache plugin <= 6.5.1 - Privilege Escalation vulnerability CVSS 3.1CRITICAL 9.8
- TI-2023-24061 WordPress LiteSpeed Cache plugin <= 5.7 - Unauthenticated Broken Access Control on API vulnerability CVSS 3.1HIGH 8.2
Sources
- CVE-2021-24964 · CVE Program
- CVE-2021-24964 · NVD
- FIRST EPSS
- GHSA-fg4h-vrcg-56rq · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences