Read the docs

litespeedtech

Records47All Threatist records
Exploited (KEV)2In CISA KEV
CVSS critical8CVSS 9.0–10.0
CVSS high18CVSS 7.0–8.9

Exploited now

litespeedtech records in CISA KEV

Components

Products in the NVD configurations · select one to filter the records

Records

47 records

Priority CRITICAL 96KEV

LiteSpeed cPanel plugin before 2.4.8 (as distributed in LiteSpeed WHM PlugIn before 5.3.2.0) mishandles symlinks provided by a user with FTP or web shell access on a shared hosting server running CloudLinux/CageFS, as ex…

CVSS 3.1HIGH 8.5 Network Low privileges No interaction EPSS 0.01439 Published 2026-06-14 Fixed in 2.4.8 CWE-61
Priority CRITICAL 90

Insufficiently Protected Credentials vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Authentication Bypass.This issue affects LiteSpeed Cache: from n/a through < 6.5.0.1.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.82335 Published 2024-10-20 No fix listed CWE-522
Priority HIGH 73

Improper Input Validation vulnerability in LiteSpeed Technologies OpenLiteSpeed Web Server and LiteSpeed Web Server dashboards allows Command Injection.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.09736 Published 2022-10-27 Fixed in 1.7.16.1 CWE-20
Priority HIGH 69

OpenLiteSpeed through 1.9.4 contains an authentication bypass vulnerability that allows unauthenticated remote attackers to evade virtual host client certificate requirements over HTTP/3.

CVSS 4.0HIGH 8.2 Network No auth No interaction EPSS 0.00289 Published 2026-10-30 No fix listed CWE-295
Priority MEDIUM 60

The LiteSpeed Cache WordPress plugin before 4.4.4 does not properly verify that requests are coming from QUIC.cloud servers, allowing attackers to make requests to certain endpoints by using a specific X-Forwarded-For he…

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.01236 Published 2022-01-03 Fixed in 4.4.4 CWE-79
Priority MEDIUM 47

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'esi' shortcode in versions up to, and including, 5.6 due to insufficient input sanitization and output escaping on user suppl…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.19501 Published 2024-01-11 No fix listed CWE-79
Priority MEDIUM 45

Incorrect Privilege Assignment vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Privilege Escalation.This issue affects LiteSpeed Cache: from n/a through <= 6.5.1.

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.00899 Published 2024-10-29 No fix listed CWE-266
Priority MEDIUM 42

LiteSpeed Web Server (LSWS) before 6.3.7 build 1 mishandles internal redirect URL validation in a certain "corner case" of %252e%252e double decoding, letting a low-privileged tenant execute code in the context of a diff…

CVSS 4.0CRITICAL 9.4 Network Low privileges No interaction EPSS 0.00352 Published 2026-09-30 Fixed in 6.3.7 build 1 CWE-174
Priority MEDIUM 42

OpenLiteSpeed and LSWS Enterprise provided by LiteSpeed Technologies contain an OS command injection vulnerability.

CVSS 4.0HIGH 8.6 Network High privileges No interaction EPSS 0.01471 Published 2026-03-16 No fix listed CWE-78
Priority MEDIUM 41

The LiteSpeed Cache plugin for WordPress is vulnerable to unauthenticated disclosure of sensitive WooCommerce customer data in all versions up to, and including, 7.9.1 With Cache REST enabled (the shipped default cache-r…

CVSS 3.1HIGH 8.2 Network No auth No interaction EPSS 0.0023 Published 2026-11-05 No fix listed CWE-200
Priority MEDIUM 41

Relative Path Traversal vulnerability in LiteSpeed Technologies LiteSpeed Cache litespeed-cache allows Path Traversal.This issue affects LiteSpeed Cache: from n/a through <= 6.4.1.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00647 Published 2024-10-16 No fix listed CWE-23
Priority MEDIUM 41

Untrusted Search Path vulnerability in LiteSpeed Technologies OpenLiteSpeed Web Server and LiteSpeed Web Server Container allows Privilege Escalation.

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.01433 Published 2022-10-27 Fixed in 1.7.16.1 CWE-426
Priority LOW 39

In lsquic before 4.9.0, the HTTP/3 implementation can use an excessive amount of memory because the number of buffered header sets is not limited, as demonstrated by a QPACK amplification attack.

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00446 Published 2026-10-22 Fixed in 4.9.0 CWE-770
Priority LOW 38

The LiteSpeed Cache plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the /wp-json/litespeed/v1/notify_ccss and /wp-json/litespeed/v1/notify_ucss REST API endpoints in all versions up to, and includin…

CVSS 3.1HIGH 7.2 Network No auth No interaction EPSS 0.00359 Published 2026-05-27 No fix listed CWE-79
Load more
Open these records in search →