Five Star Restaurant Reservations < 2.4.8 - Subscriber+ Stored Cross-Site Scripting
Priority LOW 25CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Five Star Restaurant Reservations WordPress plugin before 2.4.8 does not have capability and CSRF checks in the rtb_welcome_set_schedule AJAX action, allowing any authenticated users to call it. Due to the lack of sanitisation and escaping, users with a role as low as subscriber could perform Cross-Site Scripting attacks against logged in admins
Why it matters now
EPSS 0.00607 49th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Five Star Restaurant Reservations – WordPress Booking Plugin (Unknown): 2.4.8
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Five Star Restaurant Reservations – WordPress Booking Plugin | 2.4.8 to before 2.4.8 | 2.4.8 | Patch available | CNA |
- Five Star Restaurant Reservations – WordPress Booking Plugin VendorUnknown Affected 2.4.8 to before 2.4.8 Fixed in 2.4.8 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fivestarplugins:five_star_restaurant_reservations:*:*:*:*:*:wordpress:*:* | before 2.4.8 | Vulnerable | Five Star Plugins |
- cpe:2.3:a:fivestarplugins:five_star_restaurant_reservations:*:*:*:*:*:wordpress:*:* Versions before 2.4.8 Vulnerable ·Five Star Plugins
Remediation
- Fix · CNA Five Star Restaurant Reservations – WordPress Booking Plugin (Unknown) Fixed in 2.4.8
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24965
- 2026-10-03 Alias added: GHSA-fvjh-pxch-48xx
References
More Five Star Plugins Five Star Restaurant Reservations vulnerabilities
- TI-2022-00345 Five Star Restaurant Reservations < 2.4.12 - Unauthenticated Arbitrary Payment Status Update to Stored XSS CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-24965 · CVE Program
- CVE-2021-24965 · NVD
- FIRST EPSS
- GHSA-fvjh-pxch-48xx · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences