Five Star Restaurant Reservations < 2.4.12 - Unauthenticated Arbitrary Payment Status Update to Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.
Summary
The Five Star Restaurant Reservations WordPress plugin before 2.4.12 does not have authorisation when changing whether a payment was successful or failed, allowing unauthenticated users to change the payment status of arbitrary bookings. Furthermore, due to the lack of sanitisation and escaping, attackers could perform Cross-Site Scripting attacks against a logged in admin viewing the failed payments
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Five Star Restaurant Reservations | before 2.4.12 | 2.4.12 | Patch available | CNA |
- Five Star Restaurant Reservations VendorUnknown Affected before 2.4.12 Fixed in 2.4.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:fivestarplugins:five_star_restaurant_reservations:*:*:*:*:*:wordpress:*:* | before 2.4.12 | Vulnerable | Five Star Plugins |
- cpe:2.3:a:fivestarplugins:five_star_restaurant_reservations:*:*:*:*:*:wordpress:*:* Versions before 2.4.12 Vulnerable ·Five Star Plugins
Remediation
- Fix · CNA Five Star Restaurant Reservations (Unknown) Fixed in 2.4.12
Timeline
- 2026-10-02 Threatist record created from CVE-2022-0421
- 2026-10-03 Alias added: GHSA-rm3p-6j6m-68q8
References
More Five Star Plugins Five Star Restaurant Reservations vulnerabilities
- TI-2021-07244 Five Star Restaurant Reservations < 2.4.8 - Subscriber+ Stored Cross-Site Scripting CVSS 3.1MEDIUM 5.4
Sources
- CVE-2022-0421 · CVE Program
- CVE-2022-0421 · NVD
- FIRST EPSS
- GHSA-rm3p-6j6m-68q8 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences