Directorist – Business Directory Plugin < 7.0.6.2 - CSRF to Remote File Upload
Priority LOW 34CWE-352Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Tampering, Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-434.
Summary
The Directorist WordPress plugin before 7.0.6.2 was vulnerable to Cross-Site Request Forgery to Remote File Upload leading to arbitrary PHP shell uploads in the wp-content/plugins directory.
Why it matters now
EPSS 0.00837 57th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed Directorist – Business Directory Plugin (Unknown): 7.0.6.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Directorist – Business Directory Plugin | 7.0.6.2 to before 7.0.6.2 | 7.0.6.2 | Patch available | CNA |
- Directorist – Business Directory Plugin VendorUnknown Affected 7.0.6.2 to before 7.0.6.2 Fixed in 7.0.6.2 Patch available CNA
Remediation
- Fix · CNA Directorist – Business Directory Plugin (Unknown) Fixed in 7.0.6.2
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24981
- 2026-10-03 Alias added: GHSA-g47h-745c-4p4f
References
More wpWax Directorist vulnerabilities
- TI-2022-03630 Directorist < 7.4.4 - Subscriber+ Sensitive Information Disclosure CVSS 3.1MEDIUM 6.5
- TI-2022-03605 Directorist < 7.4.2.2 - Subscriber+ Arbitrary User Password Update via IDOR CVSS 3.1MEDIUM 6.5
- TI-2023-02111 Directorist < 7.5.4 - Admin+ LFI CVSS 3.1LOW 2.7
- TI-2025-01351 Weak password recovery in wpWax Directorist: AI-Powered Business Directory, Listings &… CVSS 3.1CRITICAL 9.8
- TI-2023-01774 Directorist <= 7.5.4 - Authenticated (Subscriber+) Arbitrary User Password Reset to Privilege Escalation CVSS 3.1HIGH 8.8
- TI-2023-22198 WordPress Directorist Plugin <= 7.7.1 is vulnerable to CSV Injection CVSS 3.1HIGH 8.8
Sources
- CVE-2021-24981 · CVE Program
- CVE-2021-24981 · NVD
- FIRST EPSS
- GHSA-g47h-745c-4p4f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences