WooCommerce PDF Invoices & Packing Slips < 2.10.5 - Reflected Cross-Site Scripting
Priority LOW 24CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The WooCommerce PDF Invoices & Packing Slips WordPress plugin before 2.10.5 does not escape the tab and section parameters before outputting it back in an attribute, leading to a Reflected Cross-Site Scripting in the admin dashboard
Why it matters now
EPSS 0.01207 68th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed WooCommerce PDF Invoices & Packing Slips (Unknown): 2.10.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WooCommerce PDF Invoices & Packing Slips | 2.10.5 to before 2.10.5 | 2.10.5 | Patch available | CNA |
- WooCommerce PDF Invoices & Packing Slips VendorUnknown Affected 2.10.5 to before 2.10.5 Fixed in 2.10.5 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:wpovernight:woocommerce_pdf_invoices\&_packing_slips:*:*:*:*:*:wordpress:*:* | before 2.10.5 | Vulnerable | wpovernight |
- cpe:2.3:a:wpovernight:woocommerce_pdf_invoices\&_packing_slips:*:*:*:*:*:wordpress:*:* Versions before 2.10.5 Vulnerable ·wpovernight
Remediation
- Fix · CNA WooCommerce PDF Invoices & Packing Slips (Unknown) Fixed in 2.10.5
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24991
- 2026-10-03 Alias added: GHSA-pmj4-hxrq-f9wh
References
More wpovernight Woocommerce Pdf Invoices& Packing Slips vulnerabilities
- TI-2024-02851 PDF Invoices & Packing Slips for WooCommerce <= 3.8.0 - Unauthenticated Stored Cross-Site Scripting CVSS 3.1HIGH 7.2
- TI-2025-18116 Unrestricted Access to PDF Documents via URL Manipulation in woocommerce-pdf-invoices-packing-slips CVSS 4.0MEDIUM 6.3
- TI-2024-14748 WordPress WooCommerce PDF Invoices & Packing Slips Plugin <= 3.7.5 is vulnerable to SQL Injection CVSS 3.1HIGH 7.6
- TI-2024-02853 PDF Invoices & Packing Slips for WooCommerce <= 3.8.0 - Unauthenticated Server-Side Request Forgery CVSS 3.1HIGH 7.2
- TI-2022-01936 WooCommerce PDF Invoices & Packing Slips < 2.16.0 - Reflected Cross-Site Scripting CVSS 3.1MEDIUM 6.1
- TI-2017-13679 The woocommerce-pdf-invoices-packing-slips plugin before 2.0.13 for WordPress has XSS via… CVSS 3.0MEDIUM 6.1
Sources
- CVE-2021-24991 · CVE Program
- CVE-2021-24991 · NVD
- FIRST EPSS
- GHSA-pmj4-hxrq-f9wh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences