WP Guppy < 1.3 - Sensitive Information Disclosure
Priority LOW 34CWE-862Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
The WP Guppy WordPress plugin before 1.3 does not have any authorisation in some of the REST API endpoints, allowing any user to call them and could lead to sensitive information disclosure, such as usernames and chats between users, as well as be able to send messages as an arbitrary user
Why it matters now
EPSS 0.02797 86th percentileScored 2026-11-07
Public exploit Yes 2 exploit referencesTagged by NVD
Fix Fixed WP Guppy (Unknown): 1.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP Guppy | 1.3 to before 1.3 | 1.3 | Patch available | CNA |
- WP Guppy VendorUnknown Affected 1.3 to before 1.3 Fixed in 1.3 Patch available CNA
Remediation
- Fix · CNA WP Guppy (Unknown) Fixed in 1.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-24997
- 2026-10-03 Alias added: GHSA-f373-v3ww-mcwj
References
Sources
- CVE-2021-24997 · CVE Program
- CVE-2021-24997 · NVD
- FIRST EPSS
- GHSA-f373-v3ww-mcwj · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences