PublishPress Capabilities < 2.3.1 - Unauthenticated Arbitrary Options Update to Blog Compromise
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Tampering, Security bypass
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-352 and CWE-862.
Summary
The PublishPress Capabilities WordPress plugin before 2.3.1, PublishPress Capabilities Pro WordPress plugin before 2.3.1 does not have authorisation and CSRF checks when updating the plugin's settings via the init hook, and does not ensure that the options to be updated belong to the plugin. As a result, unauthenticated attackers could update arbitrary blog options, such as the default role and make any new registered user with an administrator role.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | PublishPress Capabilities – User Role Access, Editor Permissions, Admin Menus | 2.0 and later; 2.3.1 to before 2.3.1 | 2.3.1 | Patch available | CNA |
| Unknown | PublishPress Capabilities Pro | 2.0 and later; 2.3.1 to before 2.3.1 | 2.3.1 | Patch available | CNA |
- PublishPress Capabilities – User Role Access, Editor Permissions, Admin Menus VendorUnknown Affected 2.0 and later; 2.3.1 to before 2.3.1 Fixed in 2.3.1 Patch available CNA
- PublishPress Capabilities Pro VendorUnknown Affected 2.0 and later; 2.3.1 to before 2.3.1 Fixed in 2.3.1 Patch available CNA
CPE configurations NVD · 2
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:publishpress:capabilities:*:*:*:*:-:wordpress:*:* | before 2.3.1 | Vulnerable | PublishPress |
| cpe:2.3:a:publishpress:capabilities:*:*:*:*:pro:wordpress:*:* | before 2.3.1 | Vulnerable | PublishPress |
- cpe:2.3:a:publishpress:capabilities:*:*:*:*:-:wordpress:*:* Versions before 2.3.1 Vulnerable ·PublishPress
- cpe:2.3:a:publishpress:capabilities:*:*:*:*:pro:wordpress:*:* Versions before 2.3.1 Vulnerable ·PublishPress
Remediation
- Fix · CNA PublishPress Capabilities – User Role Access, Editor Permissions, Admin Menus (Unknown) Fixed in 2.3.1
- Fix · CNA PublishPress Capabilities Pro (Unknown) Fixed in 2.3.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25032
- 2026-10-03 Alias added: GHSA-jvmr-8pwj-ffqf
References
More PublishPress Capabilities vulnerabilities
- TI-2022-03111 PublishPress Capabilities < 2.5.2 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
Sources
- CVE-2021-25032 · CVE Program
- CVE-2021-25032 · NVD
- FIRST EPSS
- GHSA-jvmr-8pwj-ffqf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences