Read the docs

PublishPress

Records36All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical2CVSS 9.0–10.0
CVSS high11CVSS 7.0–8.9

Exploited now

PublishPress records in CISA KEV

No PublishPress vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

36 records

Priority HIGH 67

The PublishPress Capabilities WordPress plugin before 2.5.2, PublishPress Capabilities Pro WordPress plugin before 2.5.2 unserializes the content of imported files, which could lead to PHP object injection attacks by adm…

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.01485 Published 2022-10-31 Fixed in 2.5.2 CWE-502
Priority MEDIUM 52

The PublishPress Capabilities WordPress plugin before 2.3.1, PublishPress Capabilities Pro WordPress plugin before 2.3.1 does not have authorisation and CSRF checks when updating the plugin's settings via the init hook,…

CVSS 3.1CRITICAL 9.8 Network No auth No interaction EPSS 0.07069 Published 2022-01-10 Fixed in 2.3.1 CWE-352
Priority MEDIUM 46

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in PublishPress PublishPress Revisions revisionary allows Blind SQL Injection.This issue affects PublishPress Revisions:…

CVSS 3.1CRITICAL 9.3 Network No auth No interaction EPSS 0.00252 Published 2026-03-25 No fix listed CWE-89
Priority MEDIUM 41

The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Insecure Direct Object Reference to Privilege Escalation/Account Takeover in all version…

CVSS 3.1HIGH 8.8 Network Low privileges No interaction EPSS 0.00512 Published 2024-10-17 No fix listed CWE-639
Priority LOW 39

Missing Authorization vulnerability in PublishPress PublishPress Authors publishpress-authors allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PublishPress Authors: from n/a thro…

CVSS 3.1HIGH 7.5 Network No auth No interaction EPSS 0.00298 Published 2026-03-25 No fix listed CWE-862
Priority LOW 36

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in PublishPress Gutenberg Blocks advanced-gutenberg allows PHP Local File Inclusion.This issue affects…

CVSS 3.1HIGH 7.5 Network No auth User interaction EPSS 0.00611 Published 2025-08-14 No fix listed CWE-98
Priority LOW 36

Improper Control of Filename for Include/Require Statement in PHP Program ('PHP Remote File Inclusion') vulnerability in PublishPress PublishPress Authors publishpress-authors allows PHP Local File Inclusion.This issue a…

CVSS 3.1HIGH 7.5 Network Low privileges No interaction EPSS 0.00778 Published 2025-05-07 No fix listed CWE-98
Priority LOW 35

The PublishPress Capabilities – User Role Editor, Access Permissions, User Capabilities, Admin Menus plugin for WordPress is vulnerable to Privilege Escalation in all versions up to, and including, 2.50.0.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.00639 Published 2026-09-09 No fix listed CWE-269
Priority LOW 34

Incorrect Privilege Assignment vulnerability in PublishPress PublishPress Capabilities capability-manager-enhanced allows Privilege Escalation.This issue affects PublishPress Capabilities: from n/a through 2.45.0.

CVSS 3.1HIGH 7.2 Network High privileges No interaction EPSS 0.0043 Published 2026-10-06 No fix listed CWE-266
Priority LOW 33

Improper Neutralization of Special Elements used in an SQL Command ('SQL Injection') vulnerability in PublishPress PublishPress Authors publishpress-authors allows SQL Injection.This issue affects PublishPress Authors: f…

CVSS 3.1HIGH 7.6 Network High privileges No interaction EPSS 0.00358 Published 2025-03-15 No fix listed CWE-89
Priority LOW 30

The Post Expirator WordPress plugin before 2.6.0 does not have proper capability checks in place, which could allow users with a role as low as Contributor to schedule deletion of arbitrary posts.

CVSS 3.1MEDIUM 6.5 Network Low privileges No interaction EPSS 0.00824 Published 2021-11-08 Fixed in 2.6.0 CWE-863
Priority LOW 28

The Co-Authors, Multiple Authors and Guest Authors in an Author Box with PublishPress Authors plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'name (maps to display_name)' parameter in all versi…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00193 Published 2026-10-31 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PublishPress PublishPress Authors publishpress-authors allows Stored XSS.This issue affects PublishPress Authors: from…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00139 Published 2026-10-29 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PublishPress Post Expirator post-expirator allows DOM-Based XSS.This issue affects Post Expirator: from n/a through <=…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00167 Published 2026-04-08 No fix listed CWE-79
Priority LOW 28

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in PublishPress Gutenberg Blocks advanced-gutenberg allows Stored XSS.This issue affects Gutenberg Blocks: from n/a throu…

CVSS 3.1MEDIUM 6.5 Network Low privileges User interaction EPSS 0.00192 Published 2025-07-03 No fix listed CWE-79
Priority LOW 28

The Gutenberg Blocks – PublishPress Blocks plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'Marker Title' and 'Marker Description' parameters for the Maps block in versions up to, and including,…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00231 Published 2025-10-25 No fix listed CWE-79
Priority LOW 25

The Schedule Post Changes With PublishPress Future plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'wrapper' attribute of the [futureaction] shortcode in all versions up to, and including, 4.10.…

CVSS 3.1MEDIUM 5.5 Network High privileges No interaction EPSS 0.00274 Published 2026-05-05 No fix listed CWE-79
Priority LOW 24

Authorization Bypass Through User-Controlled Key vulnerability in PublishPress PublishPress Series organize-series allows Exploiting Incorrectly Configured Access Control Security Levels.This issue affects PublishPress S…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00185 Published 2026-10-02 No fix listed CWE-639
Load more
Open these records in search →