Read the docs
TI-2021-07337 Aliases CVE-2021-25059GHSA-3wxf-wxw2-g5hj

Download Plugin < 2.0.0 - Subscriber+ Website Download

Priority MEDIUM 58Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
Low · Low · None
Fix status
Fixed

Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA.

Summary

The Download Plugin WordPress plugin before 2.0.0 does not properly validate a user has the required privileges to access a backup's nonce identifier, which may allow any users with an account on the site (such as subscriber) to download a full copy of the website.

Why it matters now

Exploitation Proof of concept CISA SSVC · not in CISA KEV
EPSS 0.00688 52nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by the CNA and NVD
Fix Fixed Download Plugin (Unknown): 2.0.0

SSVC decision points

CISA ADP · SSVC 2.0.3

Exploitation
Poc
Automatable
No
Technical impact
Partial

The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.

Affected products

VendorProductAffected versionsFixed inStatusSource
UnknownDownload Pluginbefore 2.0.02.0.0Patch availableCNA
  • Download Plugin VendorUnknown Affected before 2.0.0 Fixed in 2.0.0 Patch available CNA

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:metagauss:download_plugin:*:*:*:*:*:wordpress:*:*before 2.0.0VulnerableMetagauss
  • cpe:2.3:a:metagauss:download_plugin:*:*:*:*:*:wordpress:*:* Versions before 2.0.0 Vulnerable ·Metagauss

Remediation

  • Fix · CNA Download Plugin (Unknown) Fixed in 2.0.0

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25059
  2. 2026-10-03 Alias added: GHSA-3wxf-wxw2-g5hj
  3. 2026-10-04 EPSS moved to the 50th–90th percentile

References

  • TI-2025-05982 Download Plugin <= 2.2.8 - Authenticated (Administrator+) Arbitrary File Upload CVSS 3.1HIGH 7.2
  • TI-2022-16687 WordPress Download Plugin Plugin <= 2.0.4 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
  • TI-2024-09122 Download Plugin <= 2.2.0 - Missing Authorization to Authenticated (Subscriber+) User Metadata and Comment Download CVSS 3.1MEDIUM 6.5
  • TI-2021-06985 Download Plugin < 1.6.1 - Subscriber+ Arbitrary Plugin Activation CVSS 3.1MEDIUM 5.7

Sources