Duplicate Page or Post < 1.5.1 - Arbitrary Settings Update to Stored XSS
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Security bypass
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-862.
Summary
The Duplicate Page or Post WordPress plugin before 1.5.1 does not have any authorisation and has a flawed CSRF check in the wpdevart_duplicate_post_parametrs_save_in_db AJAX action, allowing any authenticated users, such as subscriber to call it and change the plugin's settings, or perform such attack via CSRF. Furthermore, due to the lack of escaping, this could lead to Stored Cross-Site Scripting issues
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Duplicate Page or Post | 1.5.1 to before 1.5.1 | 1.5.1 | Patch available | CNA |
- Duplicate Page or Post VendorUnknown Affected 1.5.1 to before 1.5.1 Fixed in 1.5.1 Patch available CNA
Remediation
- Fix · CNA Duplicate Page or Post (Unknown) Fixed in 1.5.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25075
- 2026-10-03 Alias added: GHSA-mm58-v9gq-hfr3
References
Sources
- CVE-2021-25075 · CVE Program
- CVE-2021-25075 · NVD
- FIRST EPSS
- GHSA-mm58-v9gq-hfr3 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences