Ocean Extra < 1.9.5 - Reflected Cross-Site Scripting
Priority LOW 30CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
The Ocean Extra WordPress plugin before 1.9.5 does not escape generated links which are then used when the OceanWP is active, leading to a Reflected Cross-Site Scripting issue
Why it matters now
EPSS 0.01444 73rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Ocean Extra (Unknown): 1.9.5
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Ocean Extra | 1.9.5 to before 1.9.5 | 1.9.5 | Patch available | CNA |
- Ocean Extra VendorUnknown Affected 1.9.5 to before 1.9.5 Fixed in 1.9.5 Patch available CNA
Remediation
- Fix · CNA Ocean Extra (Unknown) Fixed in 1.9.5
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25104
- 2026-10-03 Alias added: GHSA-gw6m-mhpj-9hgf
References
More oceanwp Ocean Extra vulnerabilities
- TI-2022-03118 Ocean Extra < 2.0.5 - Admin+ PHP Objection Injection CVSS 3.1HIGH 7.2
- TI-2023-00711 Ocean Extra < 2.1.3 - Subscriber+ Arbitrary Post Content Disclosure CVSS 3.1MEDIUM 6.5
- TI-2025-03051 Ocean Extra <= 2.4.6 - Unauthenticated Arbitrary Shortcode Execution CVSS 3.1CRITICAL 9.8
- TI-2023-26823 WordPress Ocean Extra Plugin <= 2.2.2 is vulnerable to Cross Site Request Forgery (CSRF) CVSS 3.1HIGH 8.8
- TI-2019-12232 includes/wizard/wizard.php in the Ocean Extra plugin through 1.5.8 for WordPress allows… CVSS 3.1HIGH 7.5
- TI-2024-24993 WordPress Ocean Extra plugin <= 2.2.9 - Authenticated Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
Sources
- CVE-2021-25104 · CVE Program
- CVE-2021-25104 · NVD
- FIRST EPSS
- GHSA-gw6m-mhpj-9hgf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences