Priority HIGH 67
The Ocean Extra WordPress plugin before 2.0.5 unserialises the content of an imported file, which could lead to PHP object injections issues when a high privilege user import (intentionally or not) a malicious Customizer…
CVSS 3.1HIGH 7.2· Network · High privileges · No interaction · EPSS 0.01521 · Published 2022-10-31 · Fixed in 2.0.5 CWE-502
Priority MEDIUM 62
The Ocean Extra WordPress plugin before 2.1.3 does not ensure that the template to be loaded via a shortcode is actually a template, allowing any authenticated users such as subscriber to retrieve the content of arbitrar…
CVSS 3.1MEDIUM 6.5· Network · Low privileges · No interaction · EPSS 0.00654 · Published 2023-03-13 · Fixed in 2.1.3
Priority MEDIUM 52
The Ocean Extra plugin for WordPress is vulnerable to arbitrary shortcode execution in all versions up to, and including, 2.4.6.
CVSS 3.1CRITICAL 9.8· Network · No auth · No interaction · EPSS 0.02003 · Published 2025-04-22 · No fix listed CWE-94
Priority LOW 38
Cross-Site Request Forgery (CSRF) vulnerability in OceanWP Ocean Extra.This issue affects Ocean Extra: from n/a through 2.2.2.
CVSS 3.1HIGH 8.8· Network · No auth · User interaction · EPSS 0.00286 · Published 2023-12-19 · No fix listed CWE-352
Priority LOW 36
includes/wizard/wizard.php in the Ocean Extra plugin through 1.5.8 for WordPress allows unauthenticated options changes and injection of a Cascading Style Sheets (CSS) token sequence.
CVSS 3.1HIGH 7.5· Network · No auth · No interaction · EPSS 0.01364 · Published 2019-09-11 · No fix listed CWE-287
Priority LOW 30
The Ocean Extra WordPress plugin before 1.9.5 does not escape generated links which are then used when the OceanWP is active, leading to a Reflected Cross-Site Scripting issue
CVSS 3.1MEDIUM 6.1· Network · No auth · User interaction · EPSS 0.01444 · Published 2022-06-20 · Fixed in 1.9.5 CWE-79
Priority LOW 29
Improper Neutralization of Input During Web Page Generation (XSS or 'Cross-site Scripting') vulnerability in OceanWP Ocean Extra allows Stored XSS.This issue affects Ocean Extra: from n/a through 2.2.9.
CVSS 3.1MEDIUM 6.5· Network · Low privileges · User interaction · EPSS 0.00314 · Published 2024-07-21 · No fix listed CWE-79
Priority LOW 29
The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘twitter_username’ parameter in versions up to, and including, 2.2.6 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00508 · Published 2024-04-09 · No fix listed CWE-79
Priority LOW 29
The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via custom fields in all versions up to, and including, 2.2.4 due to insufficient input sanitization and output escaping.
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00463 · Published 2024-02-20 · No fix listed CWE-79
Priority LOW 28
The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the 'ocean_gallery_id’ parameter in all versions up to, and including, 2.4.6 due to insufficient input sanitization and output escapin…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00295 · Published 2025-04-22 · No fix listed CWE-79
Priority LOW 28
The Ocean Extra plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the plugin's 'oceanwp_icon' shortcode in all versions up to, and including, 2.4.6 due to insufficient input sanitization and output es…
CVSS 3.1MEDIUM 6.4· Network · Low privileges · No interaction · EPSS 0.00295 · Published 2025-04-22 · No fix listed CWE-79
Priority LOW 25
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in OceanWP Ocean Extra plugin <= 2.1.2 versions.
CVSS 3.1MEDIUM 5.5· Network · Low privileges · User interaction · EPSS 0.00344 · Published 2023-03-30 · No fix listed CWE-79
Priority LOW 25
Auth. (contributor+) Stored Cross-Site Scripting (XSS) vulnerability in OceanWP Ocean Extra plugin <= 2.1.1 versions.
CVSS 3.1MEDIUM 5.5· Network · Low privileges · User interaction · EPSS 0.00343 · Published 2023-04-06 · No fix listed CWE-79
Priority LOW 21
The Ocean Extra plugin for WordPress is vulnerable to Cross-Site Request Forgery in versions up to, and including, 1.6.5].
CVSS 3.1MEDIUM 4.3· Network · No auth · User interaction · EPSS 0.00563 · Published 2023-07-12 · Fixed in 1.6.6 CWE-352