WP Postratings < 1.86.1 - Admin+ Stored Cross-Site Scripting
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Tampering
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CISA ADP. Fix status from CNA. Impact type from CWE-352.
Summary
The WP-PostRatings WordPress plugin before 1.86.1 does not sanitise the postratings_image parameter from its options page (wp-admin/admin.php?page=wp-postratings/postratings-options.php). Even though the page is only accessible to administrators, and protected against CSRF attacks, the issue is still exploitable when the unfiltered_html capability is disabled.
Why it matters now
SSVC decision points
CISA ADP · SSVC 2.0.3
- Exploitation
- Poc
- Automatable
- No
- Technical impact
- Partial
The decision (Track, Attend, Act) also depends on your mission and well-being impact; see CISA's SSVC guide.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | WP-PostRatings | before 1.86.1 | 1.86.1 | Patch available | CNA |
- WP-PostRatings VendorUnknown Affected before 1.86.1 Fixed in 1.86.1 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:lesterchan:wp-postratings:*:*:*:*:*:wordpress:*:* | before 1.86.1 | Vulnerable | Lester Chan |
- cpe:2.3:a:lesterchan:wp-postratings:*:*:*:*:*:wordpress:*:* Versions before 1.86.1 Vulnerable ·Lester Chan
Remediation
- Fix · CNA WP-PostRatings (Unknown) Fixed in 1.86.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25117
- 2026-10-03 Alias added: GHSA-5c46-pxg6-m63r
References
More Lester Chan Wp-postratings vulnerabilities
- TI-2023-21161 WordPress WP-PostRatings plugin <= 1.91 - Rating limit Bypass vulnerability CVSS 3.1CRITICAL 9.8
- TI-2011-04006 SQL injection vulnerability in wp-postratings.php in the WP-PostRatings plugin 1.50… CVSS 2.0MEDIUM 6.0
- TI-2024-26583 WordPress WP-PostRatings plugin <= 1.91.1 - Cross Site Scripting (XSS) vulnerability CVSS 3.1MEDIUM 6.5
- TI-2011-04609 GamerZ WP-PostRatings wp-postratings.php cross site scripting CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-25117 · CVE Program
- CVE-2021-25117 · NVD
- FIRST EPSS
- GHSA-5c46-pxg6-m63r · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences