Yoast SEO 16.7-17.2 - Unauthenticated Full Path Disclosure
Priority LOW 33CWE-200Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Information disclosure
- Confidentiality · integrity · availability
- Low · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-200.
Summary
The Yoast SEO WordPress plugin (from versions 16.7 until 17.2) discloses the full internal path of featured images in posts via the wp/v2/posts REST endpoints which could help an attacker identify other vulnerabilities or help during the exploitation of other identified vulnerabilities.
Why it matters now
EPSS 0.05632 92nd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Yoast SEO (Unknown): 17.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Unknown | Yoast SEO | 16.7 and later; 17.3 to before 17.3 | 17.3 | Patch available | CNA |
- Yoast SEO VendorUnknown Affected 16.7 and later; 17.3 to before 17.3 Fixed in 17.3 Patch available CNA
Remediation
- Fix · CNA Yoast SEO (Unknown) Fixed in 17.3
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25118
- 2026-10-03 Alias added: GHSA-946c-79cp-58mf
References
More Yoast Seo vulnerabilities
- TI-2019-10120 The Yoast SEO plugin before 11.6-RC5 for WordPress does not properly restrict unfiltered HTML in term descriptions. CVSS 3.1CRITICAL 9.8
- TI-2018-13725 A Race condition vulnerability in unzip_file in admin/import/class-import-settings.php in… CVSS 3.0MEDIUM 6.6
- TI-2023-15596 WordPress Yoast SEO: Local Plugin <= 14.8 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1HIGH 7.1
- TI-2023-13285 WordPress Yoast SEO Premium plugin <= 20.4 - Unauthenticated Zapier API Key Reset vulnerability CVSS 3.1MEDIUM 5.3
- TI-2023-13295 WordPress Yoast SEO: Local Plugin <= 14.9 is vulnerable to Cross Site Scripting (XSS) CVSS 3.1MEDIUM 6.5
- TI-2021-11783 The yoast_seo (aka Yoast SEO) extension before 7.2.1 for TYPO3 allows SSRF via a backend user account. CVSS 3.1MEDIUM 6.4
Sources
- CVE-2021-25118 · CVE Program
- CVE-2021-25118 · NVD
- FIRST EPSS
- GHSA-946c-79cp-58mf · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences