Read the docs

Yoast

Records28All Threatist records
Exploited (KEV)0None in CISA KEV
CVSS critical1CVSS 9.0–10.0
CVSS high2CVSS 7.0–8.9

Exploited now

Yoast records in CISA KEV

No Yoast vulnerabilities are listed in CISA KEV.

Components

Products in the NVD configurations · select one to filter the records

Records

28 records

Priority MEDIUM 60

A vulnerability classified as problematic was found in Google Analytics Dashboard Plugin 2.1.1.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00646 Published 2022-06-24 No fix listed CWE-80
Priority MEDIUM 55

Yoast Duplicate-Post WordPress Plugin 3.2.3 contains a persistent cross-site scripting vulnerability in plugin settings parameters.

CVSS 4.0MEDIUM 4.8 Network High privileges User interaction EPSS 0.00246 Published 2026-02-11 No fix listed
Priority LOW 37

Multiple SQL injection vulnerabilities in admin/class-bulk-editor-list-table.php in the WordPress SEO by Yoast plugin before 1.5.7, 1.6.x before 1.6.4, and 1.7.x before 1.7.4 for WordPress allow remote authenticated user…

CVSS 2.0MEDIUM 6.5 Network Low privileges Interaction — EPSS 0.05611 Published 2015-03-17 No fix listed CWE-89
Priority LOW 35

A Race condition vulnerability in unzip_file in admin/import/class-import-settings.php in the Yoast SEO (wordpress-seo) plugin before 9.2.0 for WordPress allows an SEO Manager to perform command execution on the Operatin…

CVSS 3.0MEDIUM 6.6 Network High privileges No interaction EPSS 0.03205 Published 2018-11-28 No fix listed CWE-362
Priority LOW 33

The Yoast SEO WordPress plugin (from versions 16.7 until 17.2) discloses the full internal path of featured images in posts via the wp/v2/posts REST endpoints which could help an attacker identify other vulnerabilities o…

CVSS 3.1MEDIUM 5.3 Network No auth No interaction EPSS 0.05632 Published 2022-02-28 Fixed in 17.3 CWE-200
Priority LOW 33

Multiple cross-site request forgery (CSRF) vulnerabilities in admin/class-bulk-editor-list-table.php in the WordPress SEO by Yoast plugin before 1.5.7, 1.6.x before 1.6.4, and 1.7.x before 1.7.4 for WordPress allow remot…

CVSS 2.0MEDIUM 6.8 Network No auth Interaction — EPSS 0.01521 Published 2015-03-17 No fix listed CWE-352
Priority LOW 29

The Yoast SEO plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the ‘display_name’ author meta in all versions up to, and including, 22.6 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.0063 Published 2024-05-16 No fix listed CWE-79
Priority LOW 29

The Yoast SEO plugin for WordPress is vulnerable to Reflected Cross-Site Scripting via URLs in all versions up to, and including, 22.5 due to insufficient input sanitization and output escaping.

CVSS 3.1MEDIUM 6.1 Network No auth User interaction EPSS 0.00832 Published 2024-05-09 No fix listed CWE-79
Priority LOW 28

The Yoast SEO – Advanced SEO with real-time guidance and built-in AI plugin for WordPress is vulnerable to Stored Cross-Site Scripting via Post Slug (post_name) in all versions up to, and including, 28.0 due to insuffici…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00349 Published 2026-07-25 No fix listed CWE-79
Priority LOW 28

The Yoast SEO – Advanced SEO with real-time guidance and built-in AI plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the the `jsonText` block attribute in all versions up to, and including, 27.1.1 d…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00201 Published 2026-03-22 No fix listed CWE-79
Priority LOW 28

The Yoast SEO – Advanced SEO with real-time guidance and built-in AI plugin for WordPress is vulnerable to Stored Cross-Site Scripting via the the `yoast-schema` block attribute in all versions up to, and including, 26.8…

CVSS 3.1MEDIUM 6.4 Network Low privileges No interaction EPSS 0.00223 Published 2026-02-06 No fix listed CWE-79
Priority LOW 27

Improper Neutralization of Input During Web Page Generation ('Cross-site Scripting') vulnerability in Team Yoast Yoast SEO allows Stored XSS.This issue affects Yoast SEO: from n/a through 21.0.

CVSS 3.1MEDIUM 5.9 Network High privileges User interaction EPSS 0.00427 Published 2023-11-30 No fix listed CWE-79
Priority LOW 27

A Stored Cross-Site Scripting vulnerability was discovered in the Yoast SEO WordPress plugin before 3.4.1, which had built-in blacklist filters which were blacklisting Parenthesis as well as several functions such as ale…

CVSS 3.1MEDIUM 5.4 Network Low privileges User interaction EPSS 0.01115 Published 2021-04-05 Fixed in 3.4.1 CWE-79
Priority LOW 26

Cross-site scripting (XSS) vulnerability in js/wp-seo-metabox.js in the WordPress SEO by Yoast plugin before 2.2 for WordPress allows remote attackers to inject arbitrary web script or HTML via the post_title parameter t…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.03184 Published 2015-06-17 No fix listed CWE-79
Priority LOW 25

Cross-site scripting (XSS) vulnerability in admin/google_search_console/class-gsc-table.php in the Yoast SEO plugin before 5.8.0 for WordPress allows remote attackers to inject arbitrary web script or HTML.

CVSS 3.0MEDIUM 4.8 Network High privileges User interaction EPSS 0.01345 Published 2017-11-16 No fix listed CWE-79
Priority LOW 24

The Yoast Duplicate Post plugin for WordPress is vulnerable to unauthorized modification of data due to a missing capability check on the clone_bulk_action_handler() and republish_request() functions in all versions up t…

CVSS 3.1MEDIUM 5.4 Network Low privileges No interaction EPSS 0.00182 Published 2026-03-18 Fixed in 4.6 CWE-862
Priority LOW 24

Cross-site scripting (XSS) vulnerability in the Google Analytics by Yoast (google-analytics-for-wordpress) plugin before 5.1.3 for WordPress allows remote attackers to inject arbitrary web script or HTML via the "Manuall…

CVSS 2.0MEDIUM 4.3 Network No auth Interaction — EPSS 0.01959 Published 2014-12-02 No fix listed CWE-79
Load more
Open these records in search →