Read the docs
TI-2021-07557 Aliases CVE-2021-25318GHSA-f9xf-jq4j-vqw4

rancher: API group not properly specified when creating Kubernetes RBAC resources

Priority MEDIUM 40CWE-732Published · Updated

Key facts

Attack vector
Network
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub.

Summary

A Incorrect Permission Assignment for Critical Resource vulnerability in Rancher allows users in the cluster to modify resources they should not have access to. This issue affects: Rancher versions prior to 2.5.9 ; Rancher versions prior to 2.4.16.

Why it matters now

EPSS 0.01051 64th percentileScored 2026-11-07
Fix Fixed Rancher (Rancher): 2.5.9, 2.4.16github.com/rancher/rancher (Go): 2.4.16, 2.5.9

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
RancherRancherRancher to before 2.5.92.5.9Patch availableCNA
RancherRancherRancher to before 2.4.162.4.16Patch availableCNA
—github.com/rancher/rancher (Go)2.0.0 to before 2.4.162.4.16Patch availableGHSA-f9xf-jq4j-vqw4
—github.com/rancher/rancher (Go)2.5.0 to before 2.5.92.5.9Patch availableGHSA-f9xf-jq4j-vqw4
  • Rancher VendorRancher Affected Rancher to before 2.5.9 Fixed in 2.5.9 Patch available CNA
  • Rancher VendorRancher Affected Rancher to before 2.4.16 Fixed in 2.4.16 Patch available CNA
  • github.com/rancher/rancher (Go) Vendor— Affected 2.0.0 to before 2.4.16 Fixed in 2.4.16 Patch available GHSA-f9xf-jq4j-vqw4
  • github.com/rancher/rancher (Go) Vendor— Affected 2.5.0 to before 2.5.9 Fixed in 2.5.9 Patch available GHSA-f9xf-jq4j-vqw4

CPE configurations NVD · 1

CPEVersionsRoleVendor
cpe:2.3:a:rancher:rancher:*:*:*:*:*:*:*:*before 2.4.16; 2.5.0 to before 2.5.9VulnerableRancher
  • cpe:2.3:a:rancher:rancher:*:*:*:*:*:*:*:* Versions before 2.4.16; 2.5.0 to before 2.5.9 Vulnerable ·Rancher

Remediation

  • Fix · CNA Rancher (Rancher) Fixed in 2.5.9
  • Fix · CNA Rancher (Rancher) Fixed in 2.4.16
  • Fix · GHSA-f9xf-jq4j-vqw4 github.com/rancher/rancher (Go) Fixed in 2.4.16 Advisory →
  • Fix · GHSA-f9xf-jq4j-vqw4 github.com/rancher/rancher (Go) Fixed in 2.5.9 Advisory →

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Rancher 2.5.9

    3 records Highest priority Priority MEDIUM 3 MEDIUM

    Other records, highest priority first

    • TI-2021-07559 Rancher: Cloud credentials can be used through proxy API by users without accessPriority MEDIUM 44
    • TI-2021-11979 Rancher: Privilege escalation vulnerability via malicious Connection headerPriority MEDIUM 40
  • Release ·

    Rancher 2.4.16

    2 records Highest priority Priority MEDIUM 2 MEDIUM

    Other records, highest priority first

    • TI-2021-07559 Rancher: Cloud credentials can be used through proxy API by users without accessPriority MEDIUM 44

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-25318
  2. 2026-10-03 Alias added: GHSA-f9xf-jq4j-vqw4

References

  • TI-2021-07559 Rancher: Cloud credentials can be used through proxy API by users without access CVSS 3.1CRITICAL 9.9
  • TI-2021-14897 Steve API proxy impersonation CVSS 3.1HIGH 8.8
  • TI-2021-14896 Deleting PRTBs associated to a group doesn't cause deletion of corresponding RoleBindings CVSS 3.1HIGH 8.8
  • TI-2021-11979 Rancher: Privilege escalation vulnerability via malicious Connection header CVSS 3.1HIGH 8.8

Sources