python-HyperKitty: hyperkitty-permissions.sh used during %post allows local privilege…
Priority LOW 34CWE-61Published · Updated
Key facts
- Attack vector
- Local
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
A UNIX Symbolic Link (Symlink) Following vulnerability in python-HyperKitty of openSUSE Leap 15.2, Factory allows local attackers to escalate privileges from the user hyperkitty or hyperkitty-admin to root. This issue affects: openSUSE Leap 15.2 python-HyperKitty version 1.3.2-lp152.2.3.1 and prior versions. openSUSE Factory python-HyperKitty versions prior to 1.3.4-5.1.
Why it matters now
EPSS 0.00437 38th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed Factory (openSUSE): 1.3.4-5.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| openSUSE | Leap 15.2 | python-HyperKitty – 1.3.2-lp152.2.3.1 | — | No fix listed | CNA |
| openSUSE | Factory | python-HyperKitty to before 1.3.4-5.1 | 1.3.4-5.1 | Patch available | CNA |
- Leap 15.2 VendoropenSUSE Affected python-HyperKitty – 1.3.2-lp152.2.3.1 Fixed in — No fix listed CNA
- Factory VendoropenSUSE Affected python-HyperKitty to before 1.3.4-5.1 Fixed in 1.3.4-5.1 Patch available CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:python-hyperkitty_project:python-hyperkitty:*:*:*:*:*:*:*:* | up to 1.3.2-lp152.2.3.1 | Vulnerable | Python-hyperkitty Project |
| cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* | 15.2 | Running on | openSUSE |
| cpe:2.3:a:python-hyperkitty_project:python-hyperkitty:*:*:*:*:*:*:*:* | before 1.3.4-5.1 | Vulnerable | Python-hyperkitty Project |
| cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* | not specified by NVD | Running on | openSUSE |
- cpe:2.3:a:python-hyperkitty_project:python-hyperkitty:*:*:*:*:*:*:*:* Versions up to 1.3.2-lp152.2.3.1 Vulnerable ·Python-hyperkitty Project
- cpe:2.3:o:opensuse:leap:15.2:*:*:*:*:*:*:* Versions 15.2 Running on ·openSUSE
- cpe:2.3:a:python-hyperkitty_project:python-hyperkitty:*:*:*:*:*:*:*:* Versions before 1.3.4-5.1 Vulnerable ·Python-hyperkitty Project
- cpe:2.3:a:opensuse:factory:-:*:*:*:*:*:*:* Versions not specified by NVD Running on ·openSUSE
Remediation
- Fix · CNA Factory (openSUSE) Fixed in 1.3.4-5.1
Timeline
- 2026-10-02 Threatist record created from CVE-2021-25322
- 2026-10-03 Alias added: GHSA-9p78-xgfp-85mw
References
More openSUSE vulnerabilities
- TI-2020-12851 An issue was discovered in SaltStack Salt through 3002. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-10051 rcube_image.php in Roundcube Webmail before 1.4.4 allows attackers to execute arbitrary… KEVCVSS 3.1CRITICAL 9.8
- TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01862 Improper privilege management in Apache Tomcat KEVCVSS 3.1CRITICAL 9.8
- TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
- TI-2016-03560 Unspecified vulnerability in Adobe Flash Player 21.0.0.242 and earlier allows remote… KEVCVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-25322 · CVE Program
- CVE-2021-25322 · NVD
- FIRST EPSS
- GHSA-9p78-xgfp-85mw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences