Read the docs
TI-2021-08067 Aliases CVE-2021-26117GHSA-9mgm-gcq8-86wq

ActiveMQ: LDAP-Authentication does not verify passwords on servers with anonymous bind

Priority MEDIUM 46CWE-287Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Security bypass
Confidentiality · integrity · availability
None · High · None
Fix status
Fixed

Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat. Impact type from CWE-287.

Summary

The optional ActiveMQ LDAP login module can be configured to use anonymous access to the LDAP server. In this case, for Apache ActiveMQ Artemis prior to version 2.16.0 and Apache ActiveMQ prior to versions 5.16.1 and 5.15.14, the anonymous context is used to verify a valid users password in error, resulting in no check on the password.

Why it matters now

EPSS 0.1133 96th percentileScored 2026-11-07
Fix Fixed Apache ActiveMQ (Apache Software Foundation): 2.16.0, 5.16.1org.apache.activemq:activemq-parent (Maven): 5.16.1, 5.15.14+1 more productRed Hat: 3 advisories

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
ApacheApache ActiveMQApache ActiveMQ Artemis to before 2.16.0; Apache ActiveMQ to before 5.16.12.16.0, 5.16.1Patch availableCNA
—org.apache.activemq:activemq-parent (Maven)5.16.0 to before 5.16.15.16.1Patch availableGHSA-9mgm-gcq8-86wq
—org.apache.activemq:activemq-parent (Maven)before 5.15.145.15.14Patch availableGHSA-9mgm-gcq8-86wq
—org.apache.activemq:apache-artemis (Maven)before 2.16.02.16.0Patch availableGHSA-9mgm-gcq8-86wq
  • Apache ActiveMQ VendorApache Affected Apache ActiveMQ Artemis to before 2.16.0; Apache ActiveMQ to before 5.16.1 Fixed in 2.16.0, 5.16.1 Patch available CNA
  • org.apache.activemq:activemq-parent (Maven) Vendor— Affected 5.16.0 to before 5.16.1 Fixed in 5.16.1 Patch available GHSA-9mgm-gcq8-86wq
  • org.apache.activemq:activemq-parent (Maven) Vendor— Affected before 5.15.14 Fixed in 5.15.14 Patch available GHSA-9mgm-gcq8-86wq
  • org.apache.activemq:apache-artemis (Maven) Vendor— Affected before 2.16.0 Fixed in 2.16.0 Patch available GHSA-9mgm-gcq8-86wq

CPE configurations NVD · 9

CPEVersionsRoleVendor
cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:*5.15.0 to before 5.15.14; 5.16.0 to before 5.16.1VulnerableApache
cpe:2.3:a:apache:artemis:*:*:*:*:*:*:*:*before 2.16.0VulnerableApache
cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:*not specified by NVDVulnerableNetApp
cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:*9.0VulnerableDebian
cpe:2.3:a:oracle:communications_element_manager:*:*:*:*:*:*:*:*8.2.0 – 8.2.4.0VulnerableOracle
cpe:2.3:a:oracle:communications_session_report_manager:*:*:*:*:*:*:*:*8.2.0 – 8.2.2VulnerableOracle
cpe:2.3:a:oracle:communications_session_route_manager:*:*:*:*:*:*:*:*8.0.0 – 8.2.2VulnerableOracle
cpe:2.3:a:oracle:flexcube_private_banking:12.0.0:*:*:*:*:*:*:*12.0.0VulnerableOracle
cpe:2.3:a:oracle:flexcube_private_banking:12.1.0:*:*:*:*:*:*:*12.1.0VulnerableOracle
  • cpe:2.3:a:apache:activemq:*:*:*:*:*:*:*:* Versions 5.15.0 to before 5.15.14; 5.16.0 to before 5.16.1 Vulnerable ·Apache
  • cpe:2.3:a:apache:artemis:*:*:*:*:*:*:*:* Versions before 2.16.0 Vulnerable ·Apache
  • cpe:2.3:a:netapp:oncommand_workflow_automation:-:*:*:*:*:*:*:* Versions not specified by NVD Vulnerable ·NetApp
  • cpe:2.3:o:debian:debian_linux:9.0:*:*:*:*:*:*:* Versions 9.0 Vulnerable ·Debian
  • cpe:2.3:a:oracle:communications_element_manager:*:*:*:*:*:*:*:* Versions 8.2.0 – 8.2.4.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:communications_session_report_manager:*:*:*:*:*:*:*:* Versions 8.2.0 – 8.2.2 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:communications_session_route_manager:*:*:*:*:*:*:*:* Versions 8.0.0 – 8.2.2 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:flexcube_private_banking:12.0.0:*:*:*:*:*:*:* Versions 12.0.0 Vulnerable ·Oracle
  • cpe:2.3:a:oracle:flexcube_private_banking:12.1.0:*:*:*:*:*:*:* Versions 12.1.0 Vulnerable ·Oracle

Remediation

  • Fix · CNA Apache ActiveMQ (Apache Software Foundation) Fixed in 2.16.0, 5.16.1
  • Fix · GHSA-9mgm-gcq8-86wq org.apache.activemq:activemq-parent (Maven) Fixed in 5.16.1 Advisory →
  • Fix · GHSA-9mgm-gcq8-86wq org.apache.activemq:activemq-parent (Maven) Fixed in 5.15.14 Advisory →
  • Fix · GHSA-9mgm-gcq8-86wq org.apache.activemq:apache-artemis (Maven) Fixed in 2.16.0 Advisory →

Red Hat 3 advisories

  • RHSA-2021:0384 Released 2021-02-02 · Red Hat rating Important
    Red Hat JBoss Fuse/A-MQ 6.3 R18 security and bug fix update
    • Red Hat Fuse/AMQ 6.3.18
  • RHSA-2020:5365 Released 2020-12-08 · Red Hat rating Moderate
    Red Hat AMQ Broker 7.8 release and security update
    • Red Hat AMQ
  • RHSA-2020:4154 Released 2020-10-01 · Red Hat rating Moderate
    Red Hat AMQ Broker 7.4.5 release and security update
    • Red Hat AMQ

Vendor assessments

Red Hat

Red Hat rating: Important. Red Hat's page for this CVE →

ProductStatusPlan or fix
Red Hat AMQFixed RHSA-2020:4154
Red Hat Fuse/AMQ 6.3.18Fixed RHSA-2021:0384

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-26117
  2. 2026-10-03 Alias added: GHSA-9mgm-gcq8-86wq

References

Other 36

  • TI-2023-25106 Deserialization of untrusted data in Apache ActiveMQ KEVCVSS 3.1CRITICAL 10.0
  • TI-2016-02587 The Fileserver web application in Apache ActiveMQ 5.x before 5.14.0 allows remote… KEVCVSS 3.1CRITICAL 9.8
  • TI-2026-26494 Apache ActiveMQ Broker, Apache ActiveMQ All, Apache ActiveMQ: Authenticated users could perform RCE via Jolokia MBeans KEVCVSS 3.1HIGH 8.8
  • TI-2013-05951 Xstream API versions up to 1.4.6 and version 1.4.10, if the security framework has not… CVSS 3.1CRITICAL 9.8
  • TI-2021-04451 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.1
  • TI-2021-04446 XStream is vulnerable to an Arbitrary Code Execution attack CVSS 3.1CRITICAL 9.8
See all 74 →

Sources