Apostrophe Technologies sanitize-html before 2.3.2 does not properly validate the…
Priority LOW 28CWE-20Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- None · Low · None
- Fix status
- Partial Red Hat: 2 fixed, 1 without a fix
Attack profile from CVSS 3.1 · NVD. Fix status from CNA, GitHub and Red Hat.
Summary
Apostrophe Technologies sanitize-html before 2.3.2 does not properly validate the hostnames set by the "allowedIframeHostnames" option when the "allowIframeRelativeUrls" is set to true, which allows attackers to bypass hostname whitelist for iframe element, related using an src value that starts with "/\\example.com".
Why it matters now
EPSS 0.01775 78th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Partial sanitize-html (npm): 2.3.2Red Hat: 2 advisoriesRed Hat: 2 fixed, 1 without a fix
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | sanitize-html (npm) | before 2.3.2 | 2.3.2 | Patch available | GHSA-mjxr-4v3x-q3m4 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- sanitize-html (npm) Vendor— Affected before 2.3.2 Fixed in 2.3.2 Patch available GHSA-mjxr-4v3x-q3m4
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apostrophecms:sanitize-html:*:*:*:*:*:node.js:*:* | before 2.3.2 | Vulnerable | apostrophecms |
- cpe:2.3:a:apostrophecms:sanitize-html:*:*:*:*:*:node.js:*:* Versions before 2.3.2 Vulnerable ·apostrophecms
Remediation
- Fix · GHSA-mjxr-4v3x-q3m4 sanitize-html (npm) Fixed in 2.3.2 Advisory →
Red Hat 2 advisories
- RHSA-2021:3759 Released 2021-10-18 · Red Hat rating ModerateOpenShift Container Platform 4.9.0 bug fix and security update
- Red Hat OpenShift Container Platform 4.9 openshift4/ose-baremetal-rhel8-operator, openshift4/ose-console, openshift4/ose-etcd +4
- RHSA-2021:2438 Released 2021-07-27 · Red Hat rating ModerateOpenShift Container Platform 4.8.2 bug fix and security update
- Red Hat OpenShift Container Platform 4.8 openshift4/driver-toolkit-rhel8, openshift4/egress-router-cni-rhel8, openshift4/network-tools-rhel8 +47
Vendor assessments
Red Hat
Red Hat rating: Moderate. Red Hat's page for this CVE →
| Product | Status | Plan or fix |
|---|---|---|
| OpenShift Service Mesh 2.0 | Affected | No fix yet |
| Red Hat OpenShift Container Platform 4.8 | Fixed | RHSA-2021:2438 |
| Red Hat OpenShift Container Platform 4.9 | Fixed | RHSA-2021:3759 |
Not affected: 2 products
- Red Hat OpenShift Container Platform 4.8
- Red Hat OpenShift Container Platform 4.9
Timeline
- 2026-10-02 Threatist record created from CVE-2021-26540
- 2026-10-03 Alias added: GHSA-mjxr-4v3x-q3m4
References
More apostrophecms Sanitize-html vulnerabilities
- TI-2024-14258 Information disclosure in sanitize-html CVSS 3.1MEDIUM 5.3
- TI-2026-29000 ApostropheCMS: sanitize-html allowedTags Bypass via Entity-Decoded Text in nonTextTags Elements CVSS 3.1MEDIUM 6.1
- TI-2019-15279 Cross-site scripting in sanitize-html CVSS 3.1MEDIUM 6.1
- TI-2014-08427 Cross-site scripting in sanitize-html CVSS 3.1MEDIUM 6.1
- TI-2022-09444 Regular expression denial of service (ReDoS) in sanitize-html CVSS 3.1HIGH 7.5
- TI-2016-09355 sanitize-html before 1.4.3 has XSS. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-26540 · CVE Program
- CVE-2021-26540 · NVD
- FIRST EPSS
- GHSA-mjxr-4v3x-q3m4 · GitHub Advisory Database · CC BY 4.0
- CVE-2021-26540 · Red Hat security data · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences