ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant…
Priority MEDIUM 51CWE-843Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-843 and the CVSS impact.
Summary
ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant Authentication Bypass (!= instead of !==).
Why it matters now
EPSS 0.0563 92nd percentileScored 2026-11-07
Public exploit Yes 3 exploit referencesTagged by NVD
Fix Fixed impresscms/impresscms (Packagist): 1.4.3
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | impresscms/impresscms (Packagist) | before 1.4.3 | 1.4.3 | Patch available | GHSA-m8xh-cqc2-5q6f |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- impresscms/impresscms (Packagist) Vendor— Affected before 1.4.3 Fixed in 1.4.3 Patch available GHSA-m8xh-cqc2-5q6f
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:impresscms:impresscms:*:*:*:*:*:*:*:* | before 1.4.3 | Vulnerable | ImpressCMS |
- cpe:2.3:a:impresscms:impresscms:*:*:*:*:*:*:*:* Versions before 1.4.3 Vulnerable ·ImpressCMS
Remediation
- Fix · GHSA-m8xh-cqc2-5q6f impresscms/impresscms (Packagist) Fixed in 1.4.3 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-26600
- 2026-10-03 Alias added: GHSA-m8xh-cqc2-5q6f
References
Exploit 3
More Impresscms vulnerabilities
- TI-2022-26365 ImpressCMS 1.4.4 - Unrestricted File Upload CVSS 4.0CRITICAL 9.3
- TI-2019-15755 ImpressCMS 1.3.11 SQL Injection via bid Parameter CVSS 4.0HIGH 7.1
- TI-2021-08319 ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection. CVSS 3.1CRITICAL 9.8
- TI-2023-19270 A cross-site scripting (XSS) vulnerability in ImpressCMS v1.4.5 and before allows… CVSS 3.1MEDIUM 4.8
- TI-2022-08771 ImpressCMS before 1.4.2 allows unauthenticated remote code execution via .....///… CVSS 3.1CRITICAL 9.8
- TI-2008-03313 Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack… CVSS 2.0HIGH 10.0
Sources
- CVE-2021-26600 · CVE Program
- CVE-2021-26600 · NVD
- FIRST EPSS
- GHSA-m8xh-cqc2-5q6f · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences