ImpressCMS before 1.4.2 allows unauthenticated remote code execution via .....///…
Priority MEDIUM 51CWE-22Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
ImpressCMS before 1.4.2 allows unauthenticated remote code execution via ...../// directory traversal in origName or imageName, leading to unsafe interaction with the CKEditor processImage.php script. The payload may be placed in PHP_SESSION_UPLOAD_PROGRESS when the PHP installation supports upload_progress.
Why it matters now
EPSS 0.06354 93rd percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed impresscms/impresscms (Packagist): 1.4.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | impresscms/impresscms (Packagist) | before 1.4.2 | 1.4.2 | Patch available | GHSA-389p-fchr-q2mg |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- impresscms/impresscms (Packagist) Vendor— Affected before 1.4.2 Fixed in 1.4.2 Patch available GHSA-389p-fchr-q2mg
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:impresscms:impresscms:*:*:*:*:*:*:*:* | before 1.4.2 | Vulnerable | ImpressCMS |
- cpe:2.3:a:impresscms:impresscms:*:*:*:*:*:*:*:* Versions before 1.4.2 Vulnerable ·ImpressCMS
Remediation
- Fix · GHSA-389p-fchr-q2mg impresscms/impresscms (Packagist) Fixed in 1.4.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2022-24977
- 2026-10-03 Alias added: GHSA-389p-fchr-q2mg
References
Exploit 1
Patch 2
More Impresscms vulnerabilities
- TI-2022-26365 ImpressCMS 1.4.4 - Unrestricted File Upload CVSS 4.0CRITICAL 9.3
- TI-2019-15755 ImpressCMS 1.3.11 SQL Injection via bid Parameter CVSS 4.0HIGH 7.1
- TI-2021-08319 ImpressCMS before 1.4.3 allows include/findusers.php groups SQL Injection. CVSS 3.1CRITICAL 9.8
- TI-2023-19270 A cross-site scripting (XSS) vulnerability in ImpressCMS v1.4.5 and before allows… CVSS 3.1MEDIUM 4.8
- TI-2021-08320 ImpressCMS before 1.4.3 has plugins/preloads/autologin.php type confusion with resultant… CVSS 3.1CRITICAL 9.8
- TI-2008-03313 Multiple unspecified vulnerabilities in ImpressCMS 1.0 have unknown impact and attack… CVSS 2.0HIGH 10.0
Sources
- CVE-2022-24977 · CVE Program
- CVE-2022-24977 · NVD
- FIRST EPSS
- GHSA-389p-fchr-q2mg · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences