SAP NetWeaver ABAP Server and ABAP Platform (Process Integration - Integration Builder…
Priority LOW 30Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · None · None
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA.
Summary
SAP NetWeaver ABAP Server and ABAP Platform (Process Integration - Integration Builder Framework), versions - 7.10, 7.30, 7.31, 7.40, 7.50, allows an attacker to access information under certain conditions, which would otherwise be restricted.
Why it matters now
EPSS 0.00838 58th percentileScored 2026-11-07
Fix Fixed SAP Process Integration (Integration Builder Framework) (SAP SE): 7.10, 7.30, 7.31 +2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| SAP | SAP Process Integration (Integration Builder Framework) | before 7.10; before 7.30; before 7.31; before 7.40; before 7.50 | 7.10, 7.30, 7.31, 7.40, 7.50 | Patch available | CNA |
- SAP Process Integration (Integration Builder Framework) VendorSAP Affected before 7.10; before 7.30; before 7.31; before 7.40; before 7.50 Fixed in 7.10, 7.30, 7.31, 7.40, 7.50 Patch available CNA
CPE configurations NVD · 5
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:sap:netweaver_process_integration:7.10:*:*:*:*:*:*:* | 7.10 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.30:*:*:*:*:*:*:* | 7.30 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.31:*:*:*:*:*:*:* | 7.31 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.40:*:*:*:*:*:*:* | 7.40 | Vulnerable | SAP |
| cpe:2.3:a:sap:netweaver_process_integration:7.50:*:*:*:*:*:*:* | 7.50 | Vulnerable | SAP |
- cpe:2.3:a:sap:netweaver_process_integration:7.10:*:*:*:*:*:*:* Versions 7.10 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.30:*:*:*:*:*:*:* Versions 7.30 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.31:*:*:*:*:*:*:* Versions 7.31 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.40:*:*:*:*:*:*:* Versions 7.40 Vulnerable ·SAP
- cpe:2.3:a:sap:netweaver_process_integration:7.50:*:*:*:*:*:*:* Versions 7.50 Vulnerable ·SAP
Remediation
- Fix · CNA SAP Process Integration (Integration Builder Framework) (SAP SE) Fixed in 7.10, 7.30, 7.31, 7.40, 7.50
Timeline
- 2026-10-02 Threatist record created from CVE-2021-27599
- 2026-10-03 Alias added: GHSA-x48c-g5j2-gv88
References
More SAP Netweaver Process Integration vulnerabilities
- TI-2022-19777 Missing authentication in SAP NetWeaver Process Integration CVSS 3.1CRITICAL 9.9
- TI-2022-19776 Missing authentication in SAP NetWeaver Process Integration CVSS 3.1CRITICAL 9.4
- TI-2019-00271 OS command injection in SAP NetWeaver Process Integration ABAP tests CVSS 3.0HIGH 7.2
- TI-2023-17944 Missing Authentication check in SAP NetWeaver Process Integration (Runtime Workbench) CVSS 3.1MEDIUM 6.5
- TI-2023-17943 Missing Authentication check in SAP NetWeaver Process Integration (Message Display Tool) CVSS 3.1MEDIUM 6.5
- TI-2019-00262 Under certain conditions the PI Integration Builder Web UI of SAP NetWeaver Process… CVSS 3.0HIGH 7.5
Sources
- CVE-2021-27599 · CVE Program
- CVE-2021-27599 · NVD
- FIRST EPSS
- GHSA-x48c-g5j2-gv88 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences