Buffer overflow in iLO Amplifier Pack
Key facts
- Attack vector
- Network
- Privileges required
- High
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-120 and the CVSS impact.
Summary
Multiple buffer overflow security vulnerabilities have been identified in HPE iLO Amplifier Pack version(s): Prior to 2.12. These vulnerabilities could be exploited by a highly privileged user to remotely execute code that could lead to a loss of confidentiality, integrity, and availability. HPE has provided a software update to resolve this vulnerability in HPE iLO Amplifier Pack.
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | iLO Amplifier Pack | before 2.12 | 2.12 | Patch available | CNA |
- iLO Amplifier Pack Vendor— Affected before 2.12 Fixed in 2.12 Patch available CNA
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:hp:ilo_amplifier_pack:*:*:*:*:*:*:*:* | before 2.12 | Vulnerable | Hewlett Packard Enterprise |
- cpe:2.3:a:hp:ilo_amplifier_pack:*:*:*:*:*:*:*:* Versions before 2.12 Vulnerable ·Hewlett Packard Enterprise
Remediation
- Fix · CNA iLO Amplifier Pack Fixed in 2.12
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29220
- 2026-10-03 Alias added: GHSA-gpfm-7rr9-83h4
References
More Hewlett Packard Enterprise Ilo Amplifier Pack vulnerabilities
- TI-2021-10042 Path traversal in iLO Amplifier Pack CVSS 3.1CRITICAL 9.8
- TI-2020-05815 A potential security vulnerability has been identified in HPE iLO Amplifier Pack server… CVSS 3.1CRITICAL 9.8
- TI-2021-08306 A potential security vulnerability was identified in HPE iLO Amplifier Pack. CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-29220 · CVE Program
- CVE-2021-29220 · NVD
- FIRST EPSS
- GHSA-gpfm-7rr9-83h4 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences