The @ronomon/opened library before 1.5.2 is vulnerable to a command injection…
Priority MEDIUM 49CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The @ronomon/opened library before 1.5.2 is vulnerable to a command injection vulnerability which would allow a remote attacker to execute commands on the system if the library was used with untrusted input.
Why it matters now
EPSS 0.04508 91st percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix Fixed @ronomon/opened (npm): 1.5.2
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | @ronomon/opened (npm) | before 1.5.2 | 1.5.2 | Patch available | GHSA-fg5w-w99f-rj6w |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- @ronomon/opened (npm) Vendor— Affected before 1.5.2 Fixed in 1.5.2 Patch available GHSA-fg5w-w99f-rj6w
Remediation
- Fix · GHSA-fg5w-w99f-rj6w @ronomon/opened (npm) Fixed in 1.5.2 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29300
- 2026-10-03 Alias added: GHSA-fg5w-w99f-rj6w
References
Sources
- CVE-2021-29300 · CVE Program
- CVE-2021-29300 · NVD
- FIRST EPSS
- GHSA-fg5w-w99f-rj6w · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences