The gnuplot package prior to version 0.1.0 for Node.js allows code execution via shell…
Priority MEDIUM 46CWE-78Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- Code execution
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub. Impact type from CWE-78.
Summary
The gnuplot package prior to version 0.1.0 for Node.js allows code execution via shell metacharacters in Gnuplot commands.
Why it matters now
EPSS 0.01776 78th percentileScored 2026-11-07
Fix Fixed @rkesters/gnuplot (npm): 0.1.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
| — | @rkesters/gnuplot (npm) | before 0.1.1 | 0.1.1 | Patch available | GHSA-f2jw-pr2c-9x96 |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
- @rkesters/gnuplot (npm) Vendor— Affected before 0.1.1 Fixed in 0.1.1 Patch available GHSA-f2jw-pr2c-9x96
CPE configurations NVD · 1
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:gnuplot_project:gnuplot:*:*:*:*:*:node.js:*:* | before 0.1.0 | Vulnerable | Gnuplot Project |
- cpe:2.3:a:gnuplot_project:gnuplot:*:*:*:*:*:node.js:*:* Versions before 0.1.0 Vulnerable ·Gnuplot Project
Remediation
- Fix · GHSA-f2jw-pr2c-9x96 @rkesters/gnuplot (npm) Fixed in 0.1.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29369
- 2026-10-03 Alias added: GHSA-f2jw-pr2c-9x96
References
Sources
- CVE-2021-29369 · CVE Program
- CVE-2021-29369 · NVD
- FIRST EPSS
- GHSA-f2jw-pr2c-9x96 · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences