Read the docs
TI-2021-10189 Aliases CVE-2021-29476GHSA-52qp-jpq7-6c54

Insecure Deserialization of untrusted data in rmccue/requests

Priority MEDIUM 46CWE-502Published · Updated

Key facts

Attack vector
Network
Privileges required
None
User interaction
None
Attack complexity
Low
Impact type
Code execution
Confidentiality · integrity · availability
High · High · High
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-502.

Summary

Requests is a HTTP library written in PHP. Requests mishandles deserialization in FilteredIterator. The issue has been patched and users of `Requests` 1.6.0, 1.6.1 and 1.7.0 should update to version 1.8.0.

Why it matters now

EPSS 0.02142 82nd percentileScored 2026-11-07
Fix Fixed Requests (WordPress): 1.8.0rmccue/requests (Packagist): 1.8.0

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
WordPressRequests1.6.0 to before 1.8.01.8.0Patch availableCNA
—rmccue/requests (Packagist)1.6.0 to before 1.8.01.8.0Patch availableGHSA-52qp-jpq7-6c54
  • Requests VendorWordPress Affected 1.6.0 to before 1.8.0 Fixed in 1.8.0 Patch available CNA
  • rmccue/requests (Packagist) Vendor— Affected 1.6.0 to before 1.8.0 Fixed in 1.8.0 Patch available GHSA-52qp-jpq7-6c54

CPE configurations NVD · 3

CPEVersionsRoleVendor
cpe:2.3:a:wordpress:requests:1.6.0:*:*:*:*:*:*:*1.6.0VulnerableWordPress
cpe:2.3:a:wordpress:requests:1.6.1:*:*:*:*:*:*:*1.6.1VulnerableWordPress
cpe:2.3:a:wordpress:requests:1.7.0:*:*:*:*:*:*:*1.7.0VulnerableWordPress
  • cpe:2.3:a:wordpress:requests:1.6.0:*:*:*:*:*:*:* Versions 1.6.0 Vulnerable ·WordPress
  • cpe:2.3:a:wordpress:requests:1.6.1:*:*:*:*:*:*:* Versions 1.6.1 Vulnerable ·WordPress
  • cpe:2.3:a:wordpress:requests:1.7.0:*:*:*:*:*:*:* Versions 1.7.0 Vulnerable ·WordPress

Remediation

  • Fix · CNA Requests (WordPress) Fixed in 1.8.0
  • Fix · GHSA-52qp-jpq7-6c54 rmccue/requests (Packagist) Fixed in 1.8.0 Advisory →

Vendor assessments

Red Hat

Red Hat's page for this CVE →

Not affected: 1 product
  • Red Hat

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-29476
  2. 2026-10-03 Alias added: GHSA-52qp-jpq7-6c54

References

Sources