XSS in doc_link
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- Required
- Attack complexity
- High
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · CNA. Fix status from CNA and GitHub. Impact type from CWE-79.
Summary
Adminer is open-source database management software. A cross-site scripting vulnerability in Adminer versions 4.6.1 to 4.8.0 affects users of MySQL, MariaDB, PgSQL and SQLite. XSS is in most cases prevented by strict CSP in all modern browsers. The only exception is when Adminer is using a `pdo_` extension to communicate with the database (it is used if the native extensions are not enabled). In browsers without CSP, Adminer versions 4.6.1 to 4.8.0 are affected. The vulnerability is patched in version 4.8.1. As workarounds, one can use a browser supporting strict CSP or enable the native PHP extensions (e.g. `mysqli`) or disable displaying PHP errors (`display_errors`).
Why it matters now
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Adminer | adminer | 4.7.8 to before 4.8.1 | 4.8.1 | Patch available | CNA |
| — | vrana/adminer (Packagist) | 4.7.8 to before 4.8.1 | 4.8.1 | Patch available | GHSA-2v82-5746-vwqc |
- adminer VendorAdminer Affected 4.7.8 to before 4.8.1 Fixed in 4.8.1 Patch available CNA
- vrana/adminer (Packagist) Vendor— Affected 4.7.8 to before 4.8.1 Fixed in 4.8.1 Patch available GHSA-2v82-5746-vwqc
Remediation
- Fix · CNA adminer (vrana) Fixed in 4.8.1
- Fix · GHSA-2v82-5746-vwqc vrana/adminer (Packagist) Fixed in 4.8.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-29625
- 2026-10-03 Alias added: GHSA-2v82-5746-vwqc
References
Patch 2
More Adminer vulnerabilities
- TI-2021-04411 SSRF in adminer KEVCVSS 3.1HIGH 7.2
- TI-2018-05526 Adminer through 4.3.1 has SSRF via the server parameter. CVSS 3.0CRITICAL 9.8
- TI-2021-19077 Improper Access Control in Adminer versions 1.12.0 to 4.6.2 (fixed in version 4.6.3)… CVSS 3.1HIGH 7.5
- TI-2025-28520 Adminer 4.8.1, when using Monolog for logging, allows a Denial of Service (memory… CVSS 3.1HIGH 8.6
- TI-2026-20931 Adminer has an Unauthenticated Persistent DoS via Array Injection in ?script=version Endpoint CVSS 3.1HIGH 7.5
- TI-2020-18079 Adminer through 4.7.8 allows XSS via the history parameter to the default URI. CVSS 3.1MEDIUM 6.1
Sources
- CVE-2021-29625 · CVE Program
- CVE-2021-29625 · NVD
- FIRST EPSS
- GHSA-2v82-5746-vwqc · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences