A Cross-Site Scripting (XSS) vulnerability exists within Review Board versions 3.0.20 and…
Priority LOW 26CWE-79Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- Low
- User interaction
- Required
- Attack complexity
- Low
- Impact type
- Cross-site scripting
- Confidentiality · integrity · availability
- Low · Low · None
- Fix status
- No fix listed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA. Impact type from CWE-79.
Summary
A Cross-Site Scripting (XSS) vulnerability exists within Review Board versions 3.0.20 and 4.0 RC1 and earlier. An authenticated attacker may inject malicious Javascript code when using Markdown editing within the application which remains persistent.
Why it matters now
EPSS 0.00822 57th percentileScored 2026-11-07
Public exploit Yes 1 exploit referenceTagged by NVD
Fix No fix listed No fixed version in the sources yet
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| — | — | all versions | — | No fix listed | CNA |
- — Vendor— Affected all versions Fixed in — No fix listed CNA
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:reviewboard:review_board:3.0.20:*:*:*:*:*:*:* | 3.0.20 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:review_board:4.0:beta1:*:*:*:*:*:* | 4.0 beta1 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:review_board:4.0:beta2:*:*:*:*:*:* | 4.0 beta2 | Vulnerable | Review Board |
| cpe:2.3:a:reviewboard:review_board:4.0:rc1:*:*:*:*:*:* | 4.0 rc1 | Vulnerable | Review Board |
- cpe:2.3:a:reviewboard:review_board:3.0.20:*:*:*:*:*:*:* Versions 3.0.20 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:review_board:4.0:beta1:*:*:*:*:*:* Versions 4.0 beta1 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:review_board:4.0:beta2:*:*:*:*:*:* Versions 4.0 beta2 Vulnerable ·Review Board
- cpe:2.3:a:reviewboard:review_board:4.0:rc1:*:*:*:*:*:* Versions 4.0 rc1 Vulnerable ·Review Board
Remediation
No fixed version listed by the sources yet.
Timeline
- 2026-10-02 Threatist record created from CVE-2021-31330
- 2026-10-03 Alias added: GHSA-mhg9-m5gc-hhqw
References
More Review Board vulnerabilities
- TI-2013-03864 Improper input validation in Python Software Foundation; Beanbag Djblets CVSS 3.1CRITICAL 9.8
- TI-2014-04130 The Original File and Patched File resources in Review Board 1.7.x before 1.7.27 and… CVSS 3.0MEDIUM 6.5
- TI-2013-03966 Multiple cross-site scripting (XSS) vulnerabilities in Review Board 1.6.x before 1.6.21… CVSS 2.0MEDIUM 4.3
- TI-2013-01975 Cross-site scripting (XSS) vulnerability in the auto-complete widget in… CVSS 2.0MEDIUM 4.3
- TI-2011-03779 Multiple cross-site scripting (XSS) vulnerabilities in the commenting system in Review… CVSS 2.0MEDIUM 4.3
- TI-2014-04129 Cross-site scripting (XSS) vulnerability in Review Board 1.7.x before 1.7.27 and 2.0.x… CVSS 2.0MEDIUM 4.3
Sources
- CVE-2021-31330 · CVE Program
- CVE-2021-31330 · NVD
- FIRST EPSS
- GHSA-mhg9-m5gc-hhqw · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences