Apache Kylin unsafe class loading
Priority MEDIUM 48CWE-470Published · Updated
Key facts
- Attack vector
- Network
- Privileges required
- None
- User interaction
- None
- Attack complexity
- Low
- Impact type
- —
- Confidentiality · integrity · availability
- High · High · High
- Fix status
- Fixed
Attack profile from CVSS 3.1 · NVD. Fix status from CNA and GitHub.
Summary
Kylin can receive user input and load any class through Class.forName(...). This issue affects Apache Kylin 2 version 2.6.6 and prior versions; Apache Kylin 3 version 3.1.2 and prior versions; Apache Kylin 4 version 4.0.0 and prior versions.
Why it matters now
EPSS 0.02998 87th percentileScored 2026-11-07
Fix Fixed org.apache.kylin:kylin (Maven): 3.1.3, 4.0.1
SSVC decision points
Not available: CISA has not published SSVC decision points for this record.
Affected products
| Vendor | Product | Affected versions | Fixed in | Status | Source |
|---|---|---|---|---|---|
| Apache | Apache Kylin | Apache Kylin 2 – 2.6.6; Apache Kylin 3 – 3.1.2; Apache Kylin 4 – 4.0.0 | — | No fix listed | CNA |
| — | org.apache.kylin:kylin (Maven) | before 3.1.3 | 3.1.3 | Patch available | GHSA-q656-g2x3-8cgh |
| — | org.apache.kylin:kylin (Maven) | 4.0.0 to before 4.0.1 | 4.0.1 | Patch available | GHSA-q656-g2x3-8cgh |
- Apache Kylin VendorApache Affected Apache Kylin 2 – 2.6.6; Apache Kylin 3 – 3.1.2; Apache Kylin 4 – 4.0.0 Fixed in — No fix listed CNA
- org.apache.kylin:kylin (Maven) Vendor— Affected before 3.1.3 Fixed in 3.1.3 Patch available GHSA-q656-g2x3-8cgh
- org.apache.kylin:kylin (Maven) Vendor— Affected 4.0.0 to before 4.0.1 Fixed in 4.0.1 Patch available GHSA-q656-g2x3-8cgh
CPE configurations NVD · 4
| CPE | Versions | Role | Vendor |
|---|---|---|---|
| cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:* | 2.0.0 – 2.6.6; 3.0.0 to before 3.1.3 | Vulnerable | Apache |
| cpe:2.3:a:apache:kylin:4.0.0:-:*:*:*:*:*:* | 4.0.0 | Vulnerable | Apache |
| cpe:2.3:a:apache:kylin:4.0.0:alpha:*:*:*:*:*:* | 4.0.0 alpha | Vulnerable | Apache |
| cpe:2.3:a:apache:kylin:4.0.0:beta:*:*:*:*:*:* | 4.0.0 beta | Vulnerable | Apache |
- cpe:2.3:a:apache:kylin:*:*:*:*:*:*:*:* Versions 2.0.0 – 2.6.6; 3.0.0 to before 3.1.3 Vulnerable ·Apache
- cpe:2.3:a:apache:kylin:4.0.0:-:*:*:*:*:*:* Versions 4.0.0 Vulnerable ·Apache
- cpe:2.3:a:apache:kylin:4.0.0:alpha:*:*:*:*:*:* Versions 4.0.0 alpha Vulnerable ·Apache
- cpe:2.3:a:apache:kylin:4.0.0:beta:*:*:*:*:*:* Versions 4.0.0 beta Vulnerable ·Apache
Remediation
- Fix · GHSA-q656-g2x3-8cgh org.apache.kylin:kylin (Maven) Fixed in 3.1.3 Advisory →
- Fix · GHSA-q656-g2x3-8cgh org.apache.kylin:kylin (Maven) Fixed in 4.0.1 Advisory →
Timeline
- 2026-10-02 Threatist record created from CVE-2021-31522
- 2026-10-03 Alias added: GHSA-q656-g2x3-8cgh
References
Patch 2
More Apache Kylin vulnerabilities
- TI-2020-01880 OS command injection in Apache Kylin KEVCVSS 3.1HIGH 8.8
- TI-2022-08515 OS command injection in Apache Kylin CVSS 3.1CRITICAL 9.8
- TI-2021-20543 Command injection in Apache Kylin CVSS 3.1CRITICAL 9.8
- TI-2022-21192 Apache Kylin: Command injection by Useless configuration CVSS 3.1HIGH 8.8
- TI-2020-10914 Insecure storage of sensitive information in Apache Kylin CVSS 3.1MEDIUM 5.3
- TI-2020-10903 OS command injection in Apache Kylin CVSS 3.1CRITICAL 9.8
Sources
- CVE-2021-31522 · CVE Program
- CVE-2021-31522 · NVD
- FIRST EPSS
- GHSA-q656-g2x3-8cgh · GitHub Advisory Database · CC BY 4.0
This product uses the NVD API but is not endorsed or certified by the NVD. Sources and licences