Read the docs
TI-2021-12229 Aliases CVE-2021-32555GHSA-f5pc-m8jm-j5w6

apport read_file() function could follow maliciously constructed symbolic links

Priority LOW 32CWE-59Published · Updated

Key facts

Attack vector
Local
Privileges required
Low
User interaction
None
Attack complexity
Low
Impact type
—
Confidentiality · integrity · availability
High · None · Low
Fix status
Fixed

Attack profile from CVSS 3.1 · CNA. Fix status from CNA.

Summary

It was discovered that read_file() in apport/hookutils.py would follow symbolic links or open FIFOs. When this function is used by the xorg-hwe-18.04 package apport hooks, it could expose private data to other local users.

Why it matters now

EPSS 0.00289 21st percentileScored 2026-11-07
Fix Fixed apport (Canonical): 2.20.1-0ubuntu2.30+esm1, 2.20.9-0ubuntu7.24, 2.20.11-0ubuntu27.18 +3

SSVC decision points

Not available: CISA has not published SSVC decision points for this record.

Affected products

VendorProductAffected versionsFixed inStatusSource
Canonicalapport2.20.1 to before 2.20.1-0ubuntu2.30+esm1; 2.20.9 to before 2.20.9-0ubuntu7.24; 2.20.11-0ubuntu27 to before 2.20.11-0ubuntu27.18; 2.20.11-0ubuntu50 to before 2.20.11-0ubuntu50.7; 2.20.11-0ubuntu65 to before 2.20.11-0ubuntu65.1; 2.14.1-0ubuntu3 to before 2.14.1-0ubuntu3.29+esm72.20.1-0ubuntu2.30+esm1, 2.20.9-0ubuntu7.24, 2.20.11-0ubuntu27.18, 2.20.11-0ubuntu50.7, 2.20.11-0ubuntu65.1, 2.14.1-0ubuntu3.29+esm7Patch availableCNA
  • apport VendorCanonical Affected 2.20.1 to before 2.20.1-0ubuntu2.30+esm1; 2.20.9 to before 2.20.9-0ubuntu7.24; 2.20.11-0ubuntu27 to before 2.20.11-0ubuntu27.18; 2.20.11-0ubuntu50 to before 2.20.11-0ubuntu50.7; 2.20.11-0ubuntu65 to before 2.20.11-0ubuntu65.1; 2.14.1-0ubuntu3 to before 2.14.1-0ubuntu3.29+esm7 Fixed in 2.20.1-0ubuntu2.30+esm1, 2.20.9-0ubuntu7.24, 2.20.11-0ubuntu27.18, 2.20.11-0ubuntu50.7, 2.20.11-0ubuntu65.1, 2.14.1-0ubuntu3.29+esm7 Patch available CNA

CPE configurations NVD · 5

CPEVersionsRoleVendor
cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:*18.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:*20.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:*20.10VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:21.04:*:*:*:lts:*:*:*21.04VulnerableCanonical
cpe:2.3:o:canonical:ubuntu_linux:21.10:*:*:*:*:*:*:*21.10VulnerableCanonical
  • cpe:2.3:o:canonical:ubuntu_linux:18.04:*:*:*:lts:*:*:* Versions 18.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:20.04:*:*:*:lts:*:*:* Versions 20.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:20.10:*:*:*:*:*:*:* Versions 20.10 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:21.04:*:*:*:lts:*:*:* Versions 21.04 Vulnerable ·Canonical
  • cpe:2.3:o:canonical:ubuntu_linux:21.10:*:*:*:*:*:*:* Versions 21.10 Vulnerable ·Canonical

Remediation

  • Fix · CNA apport (Canonical) Fixed in 2.20.1-0ubuntu2.30+esm1, 2.20.9-0ubuntu7.24, 2.20.11-0ubuntu27.18, 2.20.11-0ubuntu50.7, 2.20.11-0ubuntu65.1, 2.14.1-0ubuntu3.29+esm7

Fixed in the same release

Records fixed by the same vendor advisory or release, as the CNA lists them.

  • Release ·

    Canonical apport 2.14.1-0ubuntu3.29+esm7, 2.20.1-0ubuntu2.30+esm1 and 4 more versions

    11 records Highest priority Priority LOW 11 LOW

    Other records, highest priority first

    • TI-2021-12228 apport read_file() function could follow maliciously constructed symbolic linksPriority LOW 32
    • TI-2021-12227 apport read_file() function could follow maliciously constructed symbolic linksPriority LOW 32
    • TI-2021-12226 apport read_file() function could follow maliciously constructed symbolic linksPriority LOW 32

Timeline

  1. 2026-10-02 Threatist record created from CVE-2021-32555
  2. 2026-10-03 Alias added: GHSA-f5pc-m8jm-j5w6

References

  • TI-2020-09349 An issue was discovered in SaltStack Salt before 2019.2.4 and 3000 before 3000.2. KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-05854 smtp_mailaddr in smtp_session.c in OpenSMTPD 6.6, as used in OpenBSD 6.6 and other… KEVCVSS 3.1CRITICAL 9.8
  • TI-2020-01431 Netlogon Elevation of Privilege Vulnerability KEVCVSS 3.1CRITICAL 10.0
  • TI-2019-12627 Exim 4.92 through 4.92.2 allows remote code execution, a different vulnerability than… KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-08259 Underflow in PHP-FPM can lead to RCE KEVCVSS 3.1CRITICAL 9.8
  • TI-2019-07471 OS command injection in exim KEVCVSS 3.1CRITICAL 9.8
See all 4120 →

Sources